Question about 1999 Ford Expedition

1 Answer

I have 99 expedition all sudden i hit gas it dont go bogs down almost dies ...ive changed wired plugs iac..camshaft sensor fuel pump, coils, ive changed wires , the intake air temp sensor the plugs,, what is lft for me to do i cant drive it bogs to lomst .5 rpm and dont go

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,922 Answers

I will bet your 02 sensor in the exhaust manifold is the major culprit,then your egr valve on the intake manifold may be plugged,also check your map sensor(manifold air pressure)otherwise are you showing any hard-codes? if not then take out ecm fuse for 10 minutes and erase all codes on comp and replace ecm fuse and see if the engine relearns new parameters, if this all fails, get it on a dealer ship or garage computer, but it sure sounds like the 02 sensor and some have 3 in the exhaust, theyre about $50 a piece

Posted on Oct 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Car idles fine, but sputters, bogs and dies if gas pedal is pressed.


new spark plugs this decade. (a tune up?0
the filter is part of all 60k tuneups. letting it clog wrecks good pumps.
my wild guess, its lack of fuel flow, do to old filter.
or low fuel pressure.
car is identical to a Corolla. so is not unique or rare as some Geo cars are.
the cam belt not changes, invites valve kissing piston tops. BOOM
end of engine. (costs more to fix then worth of car)
the word is bogging, my engine bogs
if if bogs WOT (wide open throttle) and dont catch up < ITS NOT THE TPS. ever.
tps bad causes short bogs, called hesitations.
The map sensor , is what measure air flow and the ECU matches fuel to this air flow.
my guess, is it does that, but fuel pressure is like 15PSI, bad.

Apr 14, 2015 | 1995 Geo Prizm

1 Answer

Problems with 1996 dodge grand caravan keeps dying replaced computer sensor alternator spark plugs wires serpentine belt fuel pump coils


FUEL FILTER,,IF IT IS OLD-REPLACE!
FUEL PUMP NOT REALLY SUSPECT.....BUT POSSIBLE AS IN A THERMAL SHORTING (AFTER A SHORT TIME)
YOU HAVE TO DETERMINE WHETHER THIS DELAYED STALL ISSUE, IS COMING FROM A FUEL OR ELECTRICAL MALFUNCTION. IE: ELECTRIC CUT OUT...SUDDEN LOSS OF POWER...FUEL ISSUES: ROUGH RU..THEN SHUTS DOWNNING, BUCKING & SURGING
IF YOUR NOT FIXED...JEFF AT: JLGPROP@!YAHOO.COM THE WORX GROUP L.L.C.

Jul 02, 2014 | 1996 Dodge Grand Caravan

1 Answer

Bogs down when give it gas


Changing a fuel pump- won't cause that issue

You had other problems before the pump went in

Wasn't the fuel pressure checked at motor with
a gauge or scan tool?

Exhaust Converter could be worn out & partially clogged

Front O2 Sensors never replaced ?

Spark Plugs over 3 years old ?

Dirty MAF Sensor ?

I would check fuel trim on a road test & also
Mode #06 for cylinder misfire count

Could have a bunch of bad COP Ignition Coils
or a week battery

Feb 19, 2013 | 2000 Ford Expedition

1 Answer

1990 chevy silverado 1500 wont run


Code 12 means you are in test mode, code 34 is a problem with the map sensor, and code 35 is a problem with the idle control valve.
But those two codes could show up if you disconnect those sensors or if the engine is having other problems.
In situations where the engine stalls, it is very easy to overlook something or assume a component is working.
Treat it like a no start. Pull a plug wire and watch the spark as the engine dies. Use carb cleaner or starting fluid to boost fuel supply.
You'll have to figure out if it is loosing spark or fuel to proceed.
Things like the coil, the stator in the bottom of the dist, or a relay can be the cause. Even low fuel pressure.

Sep 17, 2012 | Chevrolet 1500 Cars & Trucks

1 Answer

My 1995 mustang 5.0 bucks and stalls. evap problem?


im having a sim issue guys.. my 95 auto. once it hits running temp it dies. checked at that temp no spark.. did the coil plugs wires dist.cap n rotor fpr purge sensor and egr sensor.

Feb 05, 2012 | Ford Mustang Cars & Trucks

3 Answers

Starts but bogs down when you give gas


CHECK YOUR FUEL INJECTORS. COULD BE DIRTY. OR JUST REPLACED. JAKE.B

Jun 16, 2010 | 1999 Dodge Ram

4 Answers

97 expedition, motor shakes and stalls


Probably fuel filter. That's where I'd start.

Aug 23, 2009 | 1997 Ford Expedition

Not finding what you are looking for?
1999 Ford Expedition Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...