Question about 1984 Mercedes-Benz Mercedes Benz 300 Class

1 Answer

No power uphill worse when cold , with vibration- repaired vacuum line some help but very little

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 369 Answers

Most likely there are even more vacuum leaks. hoses are under the front passenger seats, and go to every door and to the trunk. if you isolate the vacuum hoses from the inside of the car by plugging (use golf tees) the hoses that lead inside the car and everything works great, thats where your leak is. there are vacuum diagrams for this car available on the internet for free.

Posted on Mar 17, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

POWER LOSS UPHILL


It may be your fuel pump or a partially clogged fuel filter, you may also have a vacuum leak somewhere.

Dec 04, 2014 | Cars & Trucks

1 Answer

Moan/vibration in dash at about 2000 rpm, little worse when accelerating.


get it looked at, noise is a hands on deal.
and can be dangerous to drive, to you , the engine (or?) and public.
get it diagnosed, (location of noise is first)

Mar 14, 2014 | 2008 Suzuki SX4

1 Answer

I have a 2000 ford focus. It was vibrating on the corners as I accelerated, and very little off the line. I changed the control arms and stabilizer linkages and know it does it worse when I'm...


vibrating or shaking..side to side .. the steering wheel shaking in your hands..check driveshafts cv joints and tires for out of round or broken belts..

Feb 10, 2013 | Cars & Trucks

1 Answer

Car blows cold air then sometimes hot when excelerating can tell there is loss of power


You could have a bad (broken) vacuum line going to the dashboard area from the engine compartment. These cars use vacuum to open and close the flappers under the instrument panel that control the heat and cooling air routing. The heater controls on the dash usually just open and close valves that route vacuum to the vacuum motors that move the flappers. I had a bad vacuum line under the hood on my '95 mustang last summer. The A/C wouldn't cool the passenger compartment even though the compressor was doing fine and the fluid lines from it were cold. The vacuum line break was on the firewall in the engine compartment. It was real obvious once I figured out what to look for. That could also explain the loss of power. If there is a vacuum leak anywhere in the car, lots of other things that use vacuum don't work right either, including the engine computer etc. Also, the engine could be running lean if a vacuum line is broken, The engine is sucking extra air in through the broken vacuum connection and reduces fuel/air mix robbing you of power. The faster you run the engine, the worse it will be.

Feb 10, 2013 | 1995 Pontiac Grand Am

1 Answer

Whining coming from front


It sounds like the power steering pump has a broken pump vane and will need to be replaced and then the system flushed to get the debris out of the system so it won't ruin the new pump.

Feb 23, 2012 | 2004 Chrysler Sebring

2 Answers

96 subaru legacy, engine light comes on, has code P0304 #4 missfire,this only happens once in a while, going up a slight hill or a long hill, I have driven from seattle to portland and back with car loaded...


I fought with similar problem on my sub for a couple years. Had both a sub dealer and ind mechanic check. Spent lots of money but it still happened. Eventually I solved it by replacing vacuum hoes and putting clamps on them. Seems it was a slight vacuum leak. Worse under load (going uphill) and especially when cold.


May 19, 2010 | 1996 Subaru Legacy

1 Answer

Ac blow cold then go to heater


Does this happen when you're going uphill, or accellerating? If so, it's likely that the controls are vacuum operated. Check all the vacuum lines for cracks, look for disconnected vacuum hoses, etc. Some cars have normal drift of the controls that you speak of when under hard accelleration or going uphill.

Oct 16, 2009 | 1994 Chevrolet Corvette

1 Answer

2000 Montero Sport shutters/vibrates in 2 and 3 gears


Could be a wheel bearing and/or a rear differential pinion bearing, which usually get worse when under load(going up hill). I would definitely start there.

Aug 07, 2009 | 2002 Mitsubishi Montero

1 Answer

1995 ford bronco 5.8l surges while going uphill


check vacume lines, knock sensor, and air intake sensor

Feb 18, 2009 | 1995 Ford F350

Not finding what you are looking for?
Cars & Trucks Logo

207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...