Question about 1997 Mercury Mountaineer

2 Answers

Car idling extremely rough, battery not charging

The engine is idling extremely rough and the battery does not charge properly.
Had the alternator checked and it was functtioning properly. Replaced battery but still the same issue. Any ideas?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have the coil packs tested first , thats what was wrong with my 97 mountaineer. had 1 tower not firing and that alone made it run rough and very hesitant on take off. hope this helps you

Posted on Feb 11, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Possibly plugs, plug wires, coil packs, ignition module, fuel filter... the list goes on from that description

Posted on Oct 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Idle is rough, smoothes out around 2000 RPM, still there not as bad. Idle is below 800 RPM, not charging battery enough, checked moter mounts, mounts ok.


800 RPM is not bad and is enough to run the alternator. What you need to check is the idle air speed motor.

May 01, 2015 | 2000 Ford Windstar

2 Answers

I've had to jump my 2000 Volvo S80 several times past few months it was running fine shut off and dead used son battery to jump it it has been running rough ever since rough idle and surging


May have done something to the electronic ignition system. You may have to go to a Volvo Dealer to reprogram. Try a new battery first. My Ford had a dodgy battery and run rough as. A new battery, and she ran perfect again.

Apr 09, 2015 | Volvo Cars & Trucks

1 Answer

My 2007 Chevy Impala wouldn't start. Tried to jump it and it wouldn't start. After charging the battery for about an hour it started with a really rough idle and the dashboard read "Reduced Engine P


Possible alternator issue...let battery charge overnight..or take to Auto-zone Advance etc they check em for free if you can get it there if not charge batt overnite.

Mar 06, 2014 | Chevrolet Impala Cars & Trucks

1 Answer

94 GMC Sonoma 2wd 4.3 6 cylinder TBI. Rough idle, slow... then stalls. New iac valve, egr vacuum solenoid, and new gas tank fuel pump and filter. Battery will hold some charge After being jumped, but...


could be alternator if it doesnt charge your battery your sensors and computor dont get the right voltage and runs rough and then stalls

Feb 28, 2013 | Cars & Trucks

1 Answer

Upon startup engine idles rough then speeds up and returns to normal idle .After a couple of minutes the volt light comes on then no power then a complete shut down.Starts back up for a while then shuts...


OK, the volt light means that the alternator is not charging the battery. It could mean the battery is shorted out, or the battery is bad or low on charge due to an alternator not charging.

Replace the Alternator and battery as indicated by standard voltage output tests under load.

The computer in the car will not operate the engine properly on low voltage.

Fixing the charging system, may resolve the rough idle (meaning that it may be trying to relearn after data was erased by low voltage of the battery), and the speed up.


Try the charging system first, and once that is repaired, reevaluate the engine driveability and speed and idle smoothness, after it relearns.

Good luck on this repair.

Nov 06, 2010 | 1999 Buick LeSabre

1 Answer

My 2002 Trailblazer idles rough with the AC or defrost on when stopped. It rides fine while the car is moving. I changed my battery a couple of months ago and then the problem started. Thanks for your help


I would suggest having the Alternator checked for the proper amp output. Although it may be making enough power to keep the battery charged, it may not be making enough to power the vehicle and still be the reason the engine performs rough at low RPM's under accessory load.

Oct 29, 2010 | 2002 Chevrolet TrailBlazer

2 Answers

Can not solve Battery charging fault on my Xzara Picasso.? The battery on my Xzara went flat and " Battery Charging Fault" message came up and the battery charging light stayed on.. The garage...


If the regulator in the alternator has no feedback from the battery voltage, it will overcharge the battery OR the alternator is faulty. If the alternator is spun and a 12volt current source is put on the field terminal, it should produce 14.5Volts and no more without anything else to control it. I reckon the alternator is faulty.

Mar 18, 2017 | 1986 Chevrolet Cavalier 2 Door

1 Answer

CAR RUNS AND IDLES ROUGH, SOME BACKFIRING TYPE NOISES. WAS TOLD I HAD A IDLING MOTOR ISSUE. ALSO TRIED FUEL INJECTION CLEANER. THIS AM, CAR WAS OUTSIDE ALL NIGHT (UTAH), AND BATTERY HAD DRAINED (NO LIGHTS...


Sounds like a charging problem. When your battery runs low there is not enough current to operate the sensors properly. When you charged the battery it thought the system was fine till it gets low again. I would have your alternator checked and battery. Good luck and have a great day.

Jan 31, 2010 | 1994 Subaru Legacy Outdoor

4 Answers

Hi ,we recharged the battery in our magna and idled for about 5 minutes..when we went to drive it kept stopping every time the revs went down ...any ideas thanks larlee australia


Make sure wire conections to alternator are clean and secure. If it's still not charging properly at idle then alternator might need repair. Also make sure engine oil level is okay.

Aug 16, 2009 | Mitsubishi Passenger Cars & Trucks

1 Answer

Won't start, engine wont rev above 2000rpm


Have the alternator tested. You are providing a low charge to the battery when you jump it and when taking it above 2K RPM requires more amperage resulting in the engine dying and the rough idle

Apr 23, 2009 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1997 Mercury Mountaineer Logo

261 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

fordexpert

Level 3 Expert

5537 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...