Question about BMW 525

1 Answer

E28 525i 1983 After a recent 70 miles journey at night with no problems when I turned off the ignition the red battery light came on. I restarted the car and turned it off again but the battery light came on and stayed on. Following morning went to the car but nothing, no ignition lights at all. I removed the battery, charged it and refitted it but nothing. I did notice when refitting the battery that the tension on the fan belt was slack/ loose which I have since tightened up. Any ideas what is wrong. The car was going very well without any problems at all. Regards Brian

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 32 Answers

I think you found the problem. The system was telling you the charge function was not working

Posted on Oct 13, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power failure


first get the battery and charging system check at a shop, when the battery light come on means that ether the battery is not taking a charge anymore or the alternator it's not charging the battery. then see if you get your heater back,

Dec 24, 2013 | Nissan Pathfinder Cars & Trucks

1 Answer

Ford focus 1.6 TDCi 2008 - Car cutting out while driving. All dashboard lights on


Did you ever get to the bottom of this? I am having exactly the same issue with my 2006 Focus 1.6 tdci

Feb 22, 2013 | Cars & Trucks

1 Answer

2000 Celica GT engine misfires periodically


Hello, it could be an injector problem, try replacing the #2 injector/.

Jul 17, 2017 | 2000 Toyota Celica

1 Answer

Our c180 sport is not running as well as it normally does on travelling on an 70 mile journey it will run well but on the return journey will not go above 70 miles an hour and sounds like a vw beetle


you are describing an engine miss fire, i think you have a bad spark plug or coil probably a good old fashioned tune up will fix the problem, just remember on a merc. to use factory original parts.

Mar 09, 2011 | 2000 Mercedes-Benz C-Class

1 Answer

Car cuts off!


could be a neutral or park switch

Jan 21, 2010 | 1994 Chrysler LeBaron

1 Answer

2004 Avalanche Electrical Failure


no not a typical ignition problem. sounds like bad connection. yes check cables first. then check under hood fuse box. check engine ground. check little red box under hood by battery. check start cable connections. nice truck sorry to hear of the problem

Dec 31, 2009 | 2004 Chevrolet Avalanche

2 Answers

1983 Volvo 850 All warning lights on and no power steering


WELL SOUNDS LIKE THE BATTERY OR ALT WENT BAD BUT MAKE SHERE ALL THE BELTS ARE ON

Aug 19, 2009 | 1995 Volvo 850

1 Answer

Sudden loss of power on acord vtec Y reg


The engine light was on, but is now off? I would check for stored engine codes to hopefully get some idea as to what the heck was going on, as your confidence in taking a 200 mile trip is probably a bit shaky. Most parts stores will check for codes for free. You can post any questions u have w/ the codes here, along w/ the above info. Curt

Mar 16, 2009 | 2001 Honda Accord

2 Answers

1999 Acura TL Problem


The problem is the ignition wiring harness, as described in the May 2002 Recall 02V120000. I tried to get Acura to replace it a second time (first time they replaced it was at 75K miles) with no success. Car started stalling/restarting again at 200K miles. I bought the part mentioned in the recall (~$70) and installed it myself - have not had a reoccurrence since.

Oct 27, 2008 | 1999 Acura TL

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...