Question about 1994 Ford Escort

1 Answer

I have an extremely bad miss. I have checked the

I have an extremely bad miss. I have checked the injectors and they are fine. I have changed plugs, wires, and coil pack so I have good spark. I have also disconnected battery to try to reset the computer. What else can I try? This is a 1994 Ford Escort with a 1.9 sohc motor.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 23 Answers

Try having the electronic ignition control module checked...Also timing belt may have jumped a notch..they will stretch over time and skip a notch or two throwing it out of time.

Posted on Oct 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Missing fire


a bad injector can cause a miss, you can listen to each injector with a stethoscope. It should make a rapid clicking sound. If it makes a deep thumping sound it is likely bad. also an intake leak can cause a miss at idle. also an EGR valve partially open can cause miss at idle. I always check cylinder compression when replacing plugs or coils for a miss. You need quality tech to check for above items.

Mar 02, 2014 | Toyota Avalon Cars & Trucks

1 Answer

Starting problems


Its possible that the pressure valve relay is bad, you can try that. I had to replace one last year because it was doing the thing your talking about. I hope this helps. Alvin

Oct 17, 2013 | 1989 Mazda RX-7

1 Answer

Misfire po300 on 2.2L


Are you sure that the plug gap is correct? and did you use the recommended plug when you changed them? You might also try running a can of sea foam thru with a tank of fuel to make sure your injectors are not dirty. Also check your fuel pressure.

Apr 24, 2013 | Saturn Vue Cars & Trucks

2 Answers

Have 1996 grand cherokee lardo runs fine but has a miss changed plugs and wires still misses


check the vacuum hoses, and did you check the inside of your distributor cap for cracks or arcing. also spray some w - d 40 lightly around the mounting of the throttle body , in order to see if the gasket is leaking, you will have to start the vehicle, then while it is missing, then spray the w - d 40, and see if the engine levels out, if so , you have found a vacuum leak at the throttle body mounting.

Apr 22, 2011 | 1996 Jeep Grand Cherokee

1 Answer

1988 Toyota Camry 2.5 liter V-6. Engine starts fine, but after started it misses. The car misses terribly under a load, but will sometimes accelerate smoothly if you accelerate at a very slow pace. Will...


most misses are injector related either from dirty injectors , low fuel pressure ow injector wiring faults
use a quality injector cleaner for a tank or two
run the fault codes to check for other related sensor problems

May 23, 2017 | 1988 Toyota Camry

1 Answer

I have an 2002 buick century that has a iginition miss. We have changed the spark plugs, iginition wires, coil pack. It first came back with a miss fire number 2 cyclinder. The coil pack was changed. Now...


double check plug wires to be sure they go to the right cylinders. After that i would check fuel injectors
You need a listening device and listen for metallic clicking sound. Bad injectors will be silent and they do cause the same miss

Apr 21, 2010 | 1997 Buick LeSabre

1 Answer

92 Ranger 4.0 was running fine until i pulled out the engine to change clutch and pressure plate and put it back and now is missing. i changed the coil core, new cable and plugs, even changed injector and...


Bad ground faulty or loose wiring double check all your work prior to the replacement.
try putting all your old parts back on and see if that changes things for you

Sep 24, 2009 | Ford Ranger Cars & Trucks

3 Answers

Replaced spark plugs and wires truck is missing


i would suggest calling the police at this point .

Sep 07, 2009 | 2001 Hyundai Santa Fe

2 Answers

Has a code 0174 and 300 code checked intake gasket that was good replaced fuel pump to low of pressure took on highway ran fine but somtimes has miss on right side mostly 4 and 6


could be many things cam sensor crank sensor fuel injectors or the coil could be the issue if its a multi port fuel injected system.

Jul 18, 2009 | 2005 Chevrolet Tahoe

Not finding what you are looking for?
1994 Ford Escort Logo

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...