Question about 2005 GMC Yukon Denali

Open Question

My spedometer wont go back to zero,

It's starting at approx 60 and wont go back to zero

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 corsa c auto wont start when warm fault codes u2103 u2104 u2105 u2107


i have a meriva and battery light comes on and spedometer drops to zero then flickers i have changed alternator and still same problem sometimes car wont start fault codes are u2105 u2103 b1484 u2104 i have been told i need repair done on ecu

Nov 20, 2013 | Vauxhall Cars & Trucks

1 Answer

The battery light flashes on and off and the tac and spedometer go to zero and then back up


Yes it is a charging system problem, but whether the alternator is the cause is an open question without hands on testing.

Jun 14, 2012 | 2004 Dodge Durango

1 Answer

2006 G6 POWER STEERING SPEDOMETER AND ODEMETER GO OUT


U may have a defective Vehicle Speed Sensor (VSS), they are not very expensive and easy to replace, it is located on the ouside of the transmission.

Jan 30, 2009 | 2006 Pontiac G6

1 Answer

1999 buick lesabre wont start


my 1999 buick lasaber wont take a charge

Dec 24, 2008 | 1999 Buick Park Avenue

1 Answer

Guages in dash


I had a similar problem, it was my fuel and spedometer though. If you turn the car on and off a few times, they needles should go back to zero. The problem seems to be that they are physically worn and are getting stuck. I eventually had the instrument panel replaced for about $600 at a dealership because having to remember what speed it started at was too much of a pain. The car thinks that where ever it starts frmo is zero, so if I turned the car on and needle was stuck at 20mph then when it showed 65 I was really going 45. You may be able to live with those to gauges not resetting, I couldn't do it with the spedometer.

Nov 02, 2008 | 2003 Buick Rendezvous

1 Answer

I have a 1991 buick park avenue ultra


Speedometer or fuel gage?

If speedometer which is bouncing around, it is likely a bad ground near where the speed sensor wire harness (which connects the speed sensor to the rest of the "network") exits the transmission housing. It's at the very back of the transmission (you have a 4T60E trans) to the left of where the right side half-shaft leaves the trans housing. Just look for damaged wires. If none, replace the speed sensor for $50-60.

If it is the fuel gage, the sensor is probably not "zeroed"--it's reading wrong, too high, and if it were to start at true "empty", it would read right. Thus, the gage is always reading a little high (maybe a 1/8-1/10th of a tank too high?). This isn't a problem until to stop, start, or turn quickly and cause the fule to slosh around in the tank and starve the in-tank pickup which sends fuel to the engine.

If it is the fuel gage, you should simply put as much fuel in as you can and see if the needle goes far above "F". If it does, note how far it went and then practice filling the tank when the needle is that same distance above "E".

Hope this helps.

Sep 15, 2008 | 1991 Buick Park Avenue

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...