Question about 1996 Chevrolet Suburban

1 Answer

Running rough, spark plugs, distributor cap, rotor

1996 Suburban LT 1500 5.7 L350. Running rough, spark plugs, distributor cap, rotor fuel filter,were replaced and the fuel injectors were cleaned, still runs rough.is like is missing on 1 or 2 cylinders. or it could be the module control?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 6,982 Answers

First thing you need to know is which cylinders are missing. Then, don't forget there is an engine beneath the electronics. Do a quick test with a vacuum gauge and do a compression test. Check the distributor shaft for side play. If everything checks out good, then do electronic component testing. have a code check run (many parts stores do this free) and get a chiltons or haynes manual and follow test procedures in there.
I refrain from giving repair suggestions with problems like yours because people keep changing instead of testing parts. When I work on my vehicles or other peoples cars, I do testing to avoid buying expensive parts that most times won't correct the problem. At this point the most I'd suggest is to clean the mass air flow sensor wires with a Q-tip and carb cleaner...that often helps and is free. If you run into a problem with whatever you find, ask and I'll try to help.
good luck

Posted on Oct 05, 2009

Testimonial: "I followed suggestions, it did helped some what."

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 7 suburban doesn't start wants to but it doesn't start all the way and it makes a funny noise


Hard to say anything about the 'funny noise'.

The engine needs fuel, air, and spark to start and run. If any of these are lacking then it won't.

I would first remove a spark plug from each side of the engine to see what MAY be going on. If the spark plugs are wet with fuel, then I would lean towards it being an ignition problem.

If they are dry, then it could possibly be a fuel problem.

You could also remove the distributor cap to see if there is corrosion on the terminals of the cap and rotor.

I had to rescue a GM vehicle a few years ago that quit running going down the road. The engine acted like it wanted to start but just wouldn't. I did the above suggested checks and it turned out to be the distributor cap and rotor were both corroded to the point of not allowing the spark to get to the spark plug wires. New cap and rotor and it started right up and has been running ever since.

Hope this helps.

May 29, 2015 | 1993 Chevrolet Suburban

1 Answer

1999 Chev K2500 Suburban (Old Body) 5.7 / auto started running rough at accelleration, under slight load (hills, trailer, starts). No codes or MIL light. Replaced plugs & wires (only owned truck for...


If you can determine the ignition system is ok, I would look at fuel pressure and the fuel filter. If the distributor was loose you may have to check base timing.

Dec 05, 2012 | Cars & Trucks

1 Answer

My 1996 oldsmobile 88 has been running terrible for the last month and gets worse every week. It won't go when I have the gas pedal floored sometimes, and then it will slowly get up to speed but takes...


Hello there good man or woman

Lets start off like this there is 50 different things that can cause these issues but will start with the simple things in a list. So here it goes

1. bad spark plugs (carbon fouled,fuel fouled,oil fouled, heat glazed, or just worn out rounded electrode's )
2. spark plug wires (there is no simple way to check this but there cheap and easy to try)
3. distributor cap & igniton rotor (or coil pack if so equipped) could be corroded carbon glazed heat glazed again thought both rotor button and distributor cap are cheap and easy to change. If it is a coil cheap to and just as easy on both this is were plug wires connet to on the oppsite end of spark plugs.
4. coil pick up (this sits underneath distributor cap and rotor and is cheap and easy to fix aswell)
5. clogged air filter
6. bad pcv valve
7. bad egr valve
8. bad fuel pressure regulator
9.bad fuel pump or clogged strainer
10. vaccum line leaking or off

I know with all that being said may sound overwelming but most are easy to fix and cheap this is what i would so first do a good tune up this includes new spark plugs , plug wires, air filter , pcv valve,fuel filter distributor cap and rotor (or coil pack if so equipped ) .

That will most likley fix your problem

If it helps please leave 4 thumbs up and if it works a testomnial thanks

May 20, 2011 | 1996 Oldsmobile 88

1 Answer

I have a 87 Suburban V10 I have change temp sensor, new throttle body, map sensor, spark plugs. wires, and still can't figure it out. Went to pass someone and it started flooding itself and would not stay...


Change your fuel filter. Replace the distributor cap and rotor. If you have the HEI ignition, they are really bad about burning through the igniton rotor.

Dec 19, 2010 | 1987 Chevrolet Suburban

2 Answers

Ford F150 engine backfiring, running/idling rough


I Have a 1999 ford f150 4.6 that back fires and is just running really ruff when idling alot of nack fire a sord of like a pulse going on what is my problem?

Apr 16, 2010 | Ford F-150 Cars & Trucks

2 Answers

94 chevy k1500 5.7L engine won't run properly.


It could and most likely is a faulty Fuel pump.

Sep 12, 2009 | 1994 Chevrolet K1500

1 Answer

I have a 98 1500 that shakes on the uphill grade


first try running a high grade fuel injector cleaner in the truck, then pull out each spark plug and examine its condition if you find a black one replace the plug first if problem persists replace all plug wires and plugs the the distributor cap and rotor. Sometimes a MAF sensor can cause this problem

Aug 05, 2009 | 1998 GMC Suburban

Not finding what you are looking for?
1996 Chevrolet Suburban Logo

438 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...