Question about 1999 Chevrolet Silverado 1500

2 Answers

Will run for couple miles and engine will slow down down as if you are taking foot off of the accelerator. After a few seconds it will restart and run for another mile or two. At idle it runs fine with no indication and doesn't appear to be missing.

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,187 Answers

It is fuel-related.

Most likely thevalve that is operated by the fuel pressure regulator is sticking open. Most likely the regulator.
Check the electrical wire on it / replace unit.
You caould try using a "complete fuel system" cleaner ($12 AutoZone) and maybe it will clear up in a couple of days.

Posted on Oct 05, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 708 Answers

Sounds like a possible fuel problem. How long since you changed fuel filter? it could be clogged or your pump could be weak.

Posted on Oct 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

After driving for 200 or so miles, will not accelerate for 5 or more seconds when you slow down or have to stop, then it will accelerate again until you slow down!!


Need more information year make model? Was cruise control on?Or other conditions. Suggest take to a mechanic or dealer. Goodluck )

Jul 21, 2016 | Cars & Trucks

1 Answer

MY 2010 CHRYSLER TOWN AND COUNTRY TAKES A SLOW RESPONSE BEFORE TALKING OFF. I PUT MY FOOT ALL THE WAY DOWN BUT IT DELAY A COUPLE OF SECONDS BEFORE ACCELERATING


That is a drive by wire throttle set up. (No cable connects the pedal to the throttle body) I have heard of a few problems with throttle body motor lag, but i would check the pedal sensor and see if it is within the specs and do the same for the motor.

Nov 04, 2013 | Cars & Trucks

1 Answer

Pt cruiser jerks when acclerating, hesitates when not accelerating, fine when idle


I am not saying this is the solution or this is the problem but the PT cruiser suffer from code P0344 Which is the cam position sensor which causes misfire, the solution is a reflash of the ECM.But before a reflash the Camshaft postion sensor needs to be verified for working condition and if possible duplicated.Once the Check Engine light does come on you automatically go to limp home mode, This is the drag that you experience,the purpose is to protect the catalytic,in case there was a true condition with intermittent cam postion sensor,You need the check engine light code, then you can go from there.

Nov 24, 2012 | Cars & Trucks

1 Answer

My 1998 Dodge Intrepid 2.7 liter 152,000 miles idled fine in my driveway for 15 minutes while warming the car. It ran fine for about a mile and sputtered a couple of times, the engine smoothed out and then...


PROBABLY IF IT SOUNDS LIKE TAPPING YOU HAVE CLOGGED TIMING CHAIN TENSIONERS DON'T TRAY TO STARTED NO MORE.IF STILL RUNS TAKE IT TO THE NEAREST SHOP AND HAVE'M CHECK YOUR'E TENSIONERS. TO AVOID VALVE DAMAGE.

Jan 23, 2011 | 1998 Dodge Intrepid

1 Answer

Car won't run without foot on accelerator.


its very important that the throttle body especially around the throttle blade be spotless clean or they will stall every now and then. then progress to refuse to idle at all. take off the rubber air intake pipe from the top of throttle body [has 3 torqes screws] open throtle by hand and look for carbon/grease/soot etc were the throttle sits when closed. clean with toothbrush and some caeb cleaner get all black off and dont forget the blade, both sides and the edges. scrub then rinse with carb cleaner untill shiny.spray some cleaner in the hole that is on top off the body to. that is your idle air controll motor port.put back together.it will be hard to start at first so hold gas pedal half way down untill it starts then slowly [real slow] let foot off untill you are no longer pressing it. put in reverse and let it idle there a few seconds then do the same in drive. that should do it. sometimes it may stall a couple of times when driving dont hold foot on gas just let it die then restart this allows the computer to readjust its idle stratagee

May 06, 2010 | 1996 Jeep Grand Cherokee

1 Answer

In park the engine dies; only will run if given gas


It sounds like there is a problem with the Idle Air Control (IAC) valve. Its job is to open and let air into the manifold when the throttle is closed at idle. If it does not open, the engine dies at idle. The IAC is mounted on the throttle body. Possibly the valve is clogged or stuck, in which case it could be ok again if it is removed and cleaned. Or it is broken, and needs to be replaced. Or, there is a problem with its electrical connection, that needs to be traced. Good luck, let me know if you have any questions.

Mar 30, 2010 | 1993 Chevrolet Lumina

2 Answers

Need better fuel mileage it gets 12.8 miles to


You can buy a flash tuner, this will allow your E.C.U to recognize and use all the performance parts you add to the car like the intake and the exhaust, that way helping you with the fuel consumption. Good luck

Dec 30, 2009 | Ford F-150 Cars & Trucks

4 Answers

1998 Alfa Romeo 156 2.5 V6 86000 miles


reset ecu. turn ignition on. leave it for 90 seconds. turn it off and leave it for 90 seconds. start and run engine at idle for 15 minutes. dont touch the accelerator during processs

Aug 19, 2008 | 2000 Alfa Romeo 156

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

Related Topics:

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...