Question about 2004 Chevrolet TrailBlazer

2 Answers

Radio work, but speakers dont. All fuse were checked, and they are all ok. What could be the problem?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the ezact same problem please if anyone can be more helpful. and i have a after market amp for my sub but no new headunit just cut speaker wires and spliced in a rca jack

Posted on May 01, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Possible amp fuse blown, under rear seat

Posted on Oct 05, 2009

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

vwmike2001
  • 74 Answers

SOURCE: My radio is not working on my 2003 Honda element.

because of security features in newer cars. your probrably better off taking it to the dealer so they can reset the codes.

Posted on Aug 15, 2009

orb001
  • 46 Answers

SOURCE: Sound quit coming from speakers.

depends on how new the radio is, mine is fairly new and has a wire for "call mute" out of the back. its an optional wire i never used, this wire must have wire tape or something on it to keep it from grounding out. if it does, it will mute the radio like its supposed to. to remove the radio you'll need a set of these http://www.roverparts.com/Parts/LRA_76_001ABP.cfm you can find them at almost any auto parts store

Posted on Aug 12, 2010

  • 1 Answer

SOURCE: i have a nissan maxima

its a 7.5 fuse under the hood

Posted on Jan 20, 2011

deucego12665
  • 64 Answers

SOURCE: radio dosen't work. the

Have you tried hooking up different speakers? Also check the antenna. Are you getting a signal?

Posted on May 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 nissan murano radio seems to work but no sound from any speaker...I would appreciate any and all suggestions. I have checked fuses 6 & 12 on the inside and fuse 38 under hood. What else?


The fuses supplies power to the radio, if the radio lights up, the fuse is OK. I suspect a wire is out of the radio or the amplifier needs attention.

Feb 19, 2017 | Nissan Cars & Trucks

4 Answers

Mid ranged speakers dont work. Only the stock sub and dash speaker works.


Is there a loose wire on those speakers? If not they could be played out.

Jan 28, 2015 | 2004 Cadillac Deville

1 Answer

1999 Nissan Maxima gauge lights won't work and sound wont come out of speakers but radio works.


get into the fuse box and check the fuses are ok. If they are then check the wiring connection under the dash to the various gauges and at the speakers. Also check for frayed wires touching metal or other bare wires.

Jul 30, 2014 | 1999 Nissan Maxima

1 Answer

Is there a fuse for back speakers?


no there is no fuse if you have ab aftermarket radio and th speakers are not working i would recomend checking connections on back of radio if it has a stock radio check the connectors on speakers if there attached and still dont work you have blown speakers or bad wiring

Oct 28, 2012 | 2001 Mazda Protege

1 Answer

Speakers stop working, checked radio and its OK


If your Subaru has the separate power amplifier, check the 30A SBF-8 fuse in the SBF holder and the 20A fuse in the relay block (RED/BLK wire). Either or both may be loose. There is a DIN cord that connects the radio audio outputs to the power amplifier. This may be loose

Oct 19, 2012 | 2004 Subaru Legacy

1 Answer

Infinity modulus problems with car radio for 2005 Chrysler Crossfire. No sound


If the radio works the two fuses for it must be OK. 15A fuse 23 is the source of amplifier power. The amplifier is probably tucked away near the radio

Oct 10, 2012 | Cars & Trucks

1 Answer

1997 Explorer Sport no sound issue


sounds like a bad radio install or radio is bad

Jun 03, 2017 | 1997 Ford Explorer AWD

1 Answer

Radio comes but no sound. Radio seems to be working and the connections are ok. Fuses are ok.


if you dont get even a pop or crack when turned on at first, check the radios memory on the read-out on the radio face and see if its on mute setting, and if this is not the case, there are 2 fuses,one controls memory power and the other controls audio output power, check both as if one fuse is out the other cant make the radio operate properly

Dec 08, 2009 | 2002 Chevrolet Tahoe

1 Answer

Radio and cigarette lighter not working 1991 mercedes 190e


Spin or replace the fuse as the old aluminum fuses build up corrosion and dont work, or work on and off.

If its an after market radio check by removing unit and checking for fuses in line.

Jul 17, 2009 | 1991 Mercedes-Benz 190

Not finding what you are looking for?
2004 Chevrolet TrailBlazer Logo

448 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...