Question about 1999 Mazda Protege

2 Answers

Won't accelerate faster than 55mph. Loses pwr..

Hey, my 99 Madza Protege has acquired an acceleration problem. I can take off fine into the first 2 gears, however, once it shifts last gear, it starts to get sluggish and lose power around 55-60mph. Then quickly loses speed. I have changed spark plugs, wires, air filter... Please help, I'm so confused rite now.......

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 784 Answers

When you losing speed, do you lose RPM? This is important. 1- If you don't lose RPM then you have a problem with your torque converter. 2- If you lose RPM then you have a problem with fuel air mixture and this is controlled by ECM. Usually ECM is not a problem, but the problem is coming from other sensors contributing fuel: air mixture control like Air mass flow control ans Oxygen Sensor besides the throttle body valve is gummed up and need a through clean. So try to address the last one first then follow in reverse order if the case is in # 2. Good luck.

Posted on Oct 04, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Mazda Master
  • 2,007 Answers

Change fuel filter.

Posted on Oct 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 camaro engine surge on acceleration


"SURGE" Loses power a little? Common problem is the EGR valve gets a confusing message.It sees many sensor inputs from the ECU and if one of many is sending the wrong message it will open up,falsely. FIND the EGR valve and plug the vacuum source and try the car again. if problem is not there,there should be an investigation by a trained mechanic/technician.


DONT leave it plugged.

Also ,have a transmission expert drive your car so he/she can feel the problem. A tranny shop" won\'t charge you for this test drive.

Nov 26, 2012 | Chevrolet Camaro Cars & Trucks

1 Answer

Sluggish Acceleration


follow lines from tank to fuel injection system on motor

Oct 04, 2009 | 1999 Mazda Protege

1 Answer

No power at high speeds


try a tune up even the control module

Mar 22, 2009 | 1991 Jeep Wrangler

2 Answers

99 Expedition - Stutters and loses power when accelerating


My was doing the same thing, it was an EGR valve and a misfire on the #2 cylinder which required a new spark plug and a coil pack
t

Mar 06, 2009 | 1999 Ford Expedition

1 Answer

2005 Madza 6 6cylinder starts but has no acceleration


Heya,

Firs thing you can do to insure your clutch hasn't "gone" is start the car normally in gear. Obviously with your foot on the clutch. If it starts normally, your clutch is fine, if it jumps forward, it's your clutch.

Do you have any engine lights on?

Feb 25, 2009 | 2004 Mazda 6

1 Answer

Bad acceleration


it could one of these things: a bad fuel filter a head gasket or the timing is off and check all fluid levels

Feb 21, 2009 | 1990 Mazda Protege

1 Answer

1991 Suburban will not accelerate


have u checked the catalytic converter to see if its clogged?

Jan 12, 2009 | 1991 Cadillac Eldorado

Not finding what you are looking for?
1999 Mazda Protege Logo

525 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...