Question about 1995 Mitsubishi Eclipse

2 Answers

Hey i have a eclipse gst... The car is not running right at idle. Ive already posted this once, but letting you know that ive set the timing... I lined up the cams with top dead center and lined up the crank as well.. I cant get it any better. I just replaced the spark plugs and the plug wires... Dont know if a sensor has gone out like i said before there were no codes on the scanner when i scanned it the first time.. Thanks hope someone can help me.

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mitsubishi Master
  • 1,940 Answers

Check the crankshaft and camshaft sensors, and fuel pressure.

Posted on Jan 12, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 347 Answers

Check the air/fuel ratio, o2 sensor, coils

Posted on Oct 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 96 eclipse 420a. Ive replaced tps, coil pack, crank pos sensor, and relay, new plugs and wires, cleaned map and IAC. Car starts right up drivers good. Then after driving 20 mins car looses po


if your fuel pump is not bad ck the pressure , not sure of it but around 50 lbs I thing , ck the intake sometime the 4 bolts get loose and this will let to much air in and will not run right ,

Oct 21, 2014 | Cars & Trucks

1 Answer

Timming settings


IM NOT 100 PERCENT SURE BUT I THINK THEY TIME THEMSELVES WELL MINES DOES IVE BEEN TOLD IVE GOT A 99 ECLIPSE 2.0 4 CYLINDER AUTOMATIC NON TURBO????? I HOPE THIS HELPS

Mar 23, 2014 | 1998 Mitsubishi Eclipse

1 Answer

My 99 eclipse gs-t is not shifting


Have you tested the speed sensor to see if it is producing a signal going back to the computer ?

May 07, 2013 | Mitsubishi Eclipse Cars & Trucks

2 Answers

95 gst leaking antifreeze from line to turbo . Car was overheating and antifreeze was spraying out but stopped and temp went back down


are u getting steam from your exhaust system if so you could have a blown gasket or cracked head on the exhaust side ive just had the same problem

Mar 06, 2010 | 1999 Mitsubishi Eclipse

1 Answer

I have a 95' eclipse gst... The car is not running right at idle. I just replaced the water pump and reset the timing, i got it as close as possible.. I put it on a scanner and it said there were no...


To me it sounds as though the timing is off a tooth or two, Thats all it takes to cause a driveablity and idle problem. As frustrating as it may be I would recheck the timing marks.

Good luck, I hope this helps you.

Oct 03, 2009 | 1998 Mitsubishi Eclipse

1 Answer

My eclipse will start and then just die, like its gas is cut off


We just had this and it was a sensor called something like the CAM TIMING SENSOR - which gave the engine bad timing when it tried to get going. The car is great since we got it replaced - but it cost like $360 to get it all diagnosed and replaced.

Aug 06, 2009 | 2001 Mitsubishi Eclipse

1 Answer

Car idles high after its warmed up but when its not warmed up it idles really low and kinda lopes 1995 mitsubishi eclipse GST


you have to check on the fast idle control valve or pcv if it needs cleaning or replacement. Also check on vacuum leaks.

Jun 25, 2009 | 1995 Mitsubishi Eclipse

1 Answer

Engine missing and bad idle,


Hey, i may be able to help you,you should just let me know if you have a auto timing or normal manual timing,
in other words,do your ajust the timing on how fast you are driving or not.

About your wires arcing out of the boot,dialetic grease is a real good thing but as soon as it gets wet it tends to get thin and then leads away your spark.
Clean them off and use it with out the grease and see what happens,

you can also try and spray the plug on that metal hex with a clear coat and also around the plug hole...

Hope this help you...

Regards.

Sep 09, 2008 | 1991 Chevrolet S-10 Blazer

Not finding what you are looking for?
1995 Mitsubishi Eclipse Logo

149 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...