Question about 1988 Ford Ranger

1 Answer

No oil Pressure!

When I start my Ranger 2.9 it has great oil pressure, but once it gets hot 3 to 5 miles it goes to 0. What would make it do this"

James in Athens

Posted by on

  • big_possum Oct 02, 2009

    Have new oil with can of STP. Truck runs OK, but does have some light tapping.

  • big_possum Oct 02, 2009

    Put new sending unit in about six months ago - stopped for a while but then started back.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 855 Answers

You could be low on oil or the sending unit could be bad or a few other things. Lets take it one step at a time. First change the oil and filter.Recheck. Also does engine make any knocking or rattling sounds. After you do these checks leave a comment of the results and I will get back with you on the next steps depending on results.

Posted on Oct 02, 2009

Testimonial: "Thanks for working with me."

  • Ronald Park
    Ronald Park Oct 02, 2009

    Next step would be take out the sending unit and install a oil pressure gauge. You can buy one for testing purposes at an auto parts store. Start the truck and leave it idle and watch gauge. If it drops the problem is the oil pump or the pick up. If it stays normal your gauge in the truck is bad. Most likely you will find that it is internal. With the tapping noise that is where it sounds like it is going. Also the tapping can be caused by worn rockers. The oil return holes should not be clogged since you have a tapping but if you want to check remove valve covers and make sure the top of the head is clean. Let me know.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 2003 ford ranger the oil pressure guage goes to hald way then 0 back to half way truck runs great with no problems


Check the plug first. Look at the tabs in the plugs. They should be touching from one side to the other. See a gap fix or replace the plug. If it looks good, Replace the oil sending unit.

Dec 18, 2015 | Ford Cars & Trucks

1 Answer

I have a 05 z71 and lately on cold start up's the oil pressure gauge and info center tell's me low oil pressure for 3-5 seconds then the pressure comes up but not all the way after about 8-10 miles it


Oil gets thicker overtime and the oil filter gets clogged up with debris between changes/services.so cold environments cause sluggish thicker oil which takes longer warm and to reach its ideal viscosity operating temperature.A change of oil and filter would improve oil pressure reading on startup.

Feb 11, 2015 | Cars & Trucks

1 Answer

2006 Chrysler 300M 5.7 Hemi, all of a sudden the oil pressure has dropped to "0" when in idle or at a stop sign, and the light comes on, then when accelerated the light goes out and pressure resumes, and...


The check engine light means there is a trouble code stored in the car's computer. The first thing is to get this read out, to home in on the problem. Autozone will do this for free I believe.

It is not uncommon for the oil light to flicker at idle when hot, as long as the pressure rises OK at revs. Get an oil pressure reading done by temporarily replacing the pressure sender unit with a pressure gauge, and you can then tell if there is a problem in that area.

Nov 04, 2013 | Cars & Trucks

1 Answer

96 chevy cheynne 5.7 vortechas about 40to50 pounds oil pressure when first sart in morning and when it gets to temp. it drops to 20to25pnds and at a stop it goes to 0 and gauge light comes on until i give...


Well it could be the sending unit for the gauge.
But odds are the oil pump or engine bearings are worn out.
As the engine warms up, the metal spaces expand and the oil gets thinner. The oil pressure drops some under normal conditions, but not more than 10 or 15psi. Normal idle pressure with the engine warmed up is probably 25psi.
You could check oil pressure with a mechanical gauge to make sure its not the sending unit.
Once the oil pressure starts staying below 20psi for long periods you'll start hearing noises.

Apr 13, 2013 | 1996 Chevrolet C1500

1 Answer

2001 f-150 oil pressure gage indictates no pressure at start up


Remove the oil pressure sending unit and have a test gauge hooked up and see if the sending unit is defective. If you really have low pressure the engine should be making lots of noises.

Oct 26, 2012 | Ford F-150 Cars & Trucks

2 Answers

Oil pressure question


Hello daebbers: My name is Roger and I will be glad to help you. I assume by the way your question is written you have no objectionable engine noise. I would suspect a bad oil pressure sending unit. To check the switch will require a mechanical oil presser test. You can buy a kit at any parts store. With a cold engine. Remove the oil switch from the block. Install the mechanical gauge. after all connections are tight start the engine. Note where the pressure is at. Observe the pressure through engine warm up. As the oil and engine warm up the oil pressure will drop. According to All Data information the oil pressure at curb idle is 6 psi. This would be a min. oil pressure. If the oil pressure is higher then that is great also. Any thing less you have a internal oil leak. This would likely be a bearing issue.
PLease rate the quality of your answer. This way we know the answer you received was helpful.Should you need further help please just ask. Thank You for using Fix Ya. Roger

Sep 19, 2009 | 1996 Dodge Dakota

3 Answers

Oil pressure problem


You oil pressure sending unit has gone bad, it's common to go bad and some even leak oil. 
The oil pressure sensor is on the back of the block on the passenger side, you can get to it from the top and not from the bottom. There are (2) switches back there that screw in to the block and you can only see it from the top of the engine. The Oil Pressure Sending Unit is the one wire harness with a green and white strip on it. The other switch has more wires to it. 
When you pick up the new sensor, make sure you get the right one. make sure you get the Oil Pressure Sending Unit which sends variable oil pressure and has only one quick connect for the wire connector. The oil pressure switch is the one that only activates the oil light on older engine
Once you get the right part at Auto Zone for around $9.00, disconnect the wire clip with the green with white strip on it. and use a deep spark plug socket with a extension and u joint to get the sensor out. The sensor comes with teflon tape already and no oil should leak out from the block. It as simple as replacing a bolt and reconnecting the wire connector. 
Good luck and hope this helps, take no more then 10 min to do but about 5 hours for the engine to cool off LOL

May 29, 2009 | 2000 Ford Ranger SuperCab

1 Answer

1988 Ford ranger 2wd 2.9 5 spd fuel mileage issue


try using gas from a different place octane levels do vary.

May 05, 2009 | 1999 Ford Ranger SuperCab

1 Answer

5.3 L Yukon XL oil pressure problems


Well first the GM oil pressure sending units are notorious for false readings, so what you must do is remove the oil pressure sending unit and plug in a test mechanical gage to verify the engine has acceptable oil pressure, after you are certain the pressure is ok replace the sending unit, it requires a special socket to remove it, the socket is about $5.00 USD. There is a deep socket and a shallow, so check the sending unit for the correct socket fit.

May 02, 2017 | 2000 GMC Yukon XL

Not finding what you are looking for?
Cars & Trucks Logo

184 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5520 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...