Question about 1998 Jeep Cherokee

Open Question

Same problem here...

Apart from no power over 2000 rpm everything seems fine. Really feels like the turbo is 'missing in action'. Anyone find a solution yet?

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Truck engine with no power, and turbo dont kick in


look at fuel pressure confirm it is where it suppose to be.
as well as filter,

you did of really give a lot of info to help past this point

Jan 04, 2014 | 2000 Chevrolet S-10

1 Answer

2008 Saab turbo at idle with vibration?


The only thing I can this is a vacuum leak, either a hose or egr valve.

I hope this helps!

Nov 06, 2012 | 2008 Saab 9-3 2.0T

1 Answer

My 2000 VW Jetta TDI suddenly lost power on the interstate. It seemed that it took twice the RPMs to keep the same speed. Is this the turbo kicking off? At lower speeds it feels as if it does not change...


Most likely its your transmission slipping You will need to have it checked by a mechanic if the rpm is double then it has nothing to do with the turbo, if it's a automatic it means the clutches are slipping or if it's a standard it means the clutch is slipping from being worn out or the pressure plate is wore out.

Jun 05, 2010 | 2000 Volkswagen Jetta TDI

1 Answer

2000 Chevy s10 2.2L very rough idle at low rpm


run a fuel pressure test, if that checks out fine it may be a faulty coil pack or ignition control module

Jul 28, 2009 | 2000 Chevrolet S-10

1 Answer

'94 Saab Turbo 900 -- engine surges between 2000 and 2500 rpm


i would remove the coolant sensors and clean then to obtain the correct reading.

Jul 21, 2009 | 1994 Saab 900

1 Answer

Mitsubishi libero idling funny!!??


Do you have a check engine light on?

Mar 07, 2009 | 2001 Mercury Cougar

1 Answer

No power after 2000 rpm


changed fuel filter and disconnected batteries for 30 min. to reset computer. Truck is fine now

Dec 17, 2008 | 2003 Chevrolet Silverado 2500HD

1 Answer

Ford escort


Replace the Spark Plug wires, they burn through and short to the valve cover/cylinder head causing a miss under load, very common concern with this Mazda engine that was used in your Escort GT. Buy the best wire set you can find, or the problem will re-occur very quickly. Auto-lite makes a good set at a good price, avail at most chain parts stores like Kragen, Auto Zone etc.

Jun 06, 2008 | 1995 Ford Escort

2 Answers

2000 td 2.5 Jeep Cherokee sport


Seems like you might have wet the no 1 injector sensor..(little black plastic thing with 2 wires) It sends a pulse back to ecu and if wet it,s no good....

Jun 05, 2008 | 2000 Jeep Cherokee

Not finding what you are looking for?
1998 Jeep Cherokee Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...