Question about 1999 Dodge Caravan

1 Answer

Gauges not working lights up but no tach speedo ect.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 90 Answers

Try disconnecting the battery for a few minutes alot of times tis can reset it. be sure and disconnect the negative side.

Posted on Oct 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On my 2002 Trailblazer, when I start the engine, all my dash warning lights on and gauges stop working, the speedo and tach still work.


There is a known problem with the ignition starter switch that causes this, this is the switch that the ignition key operates when you turn it.

Sep 25, 2016 | 2002 Chevrolet TrailBlazer

1 Answer

2003 Satria, Tacho and Fuel gauge dont work . Fuel gauge comes up now & again low fuel light works. Tacho works now & again. But speedo and temp do work all the time.


It may be that the speedo and temp are mechanical, whereas the tach and fuel are electrical. Check fuse for inst. cluster for clean and tight fitment. Check electrical connection at back of inst. cluster.

Dec 09, 2014 | Cars & Trucks

1 Answer

Tach & speedo not working


Had same problem with my 2000 dodge stratus 2.4 liter and transmission would not shift out of 1st gear. Solution was ignition fuse under the hood was blown, one side of fuse working, replaced 10 am fuse everything works, tach, speedometer, gas gauge and transmission started back to shifting.

May 27, 2010 | 1996 Oldsmobile Achieva

1 Answer

Speedo and tach peg out when your driving down the hiway and the gas gauge goes to E. then it all returns to normal. I like my 2000 windstar if it was fixed. any ideas?


i did a little research and couldnt find much. it is possible that your gauges have some huge problems and that is prob the most likely. i would suggest taking the car to your dealer to have it repaired/replaced. very odd problem. more info would be awesome. what speed? only while accelerating? ect...

Aug 06, 2009 | 2000 Ford Windstar

1 Answer

Speedometer, tach, P/W and sunroof not working


it sounds like some one shorted out the electronics in the vichale very expencive job

Dec 05, 2008 | 1996 Mitsubishi Eclipse

3 Answers

Tach and speedometer gauges intermittently stay at zero


Sounds like a problem in the cluster. These years of VW the clusters could be repared but by someone who knows what they are doing seeing it's printed boards.

Oct 29, 2008 | 1995 Volkswagen Jetta

1 Answer

Second generation no speedo no tack


There is a speed sensor on the transmission. real easily changed. Very common

Oct 15, 2008 | 1994 Dodge Caravan

Not finding what you are looking for?
1999 Dodge Caravan Logo

Related Topics:

113 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...