Question about 1999 Chevrolet Silverado 1500

2 Answers

Hey I have a 1999 Chevy Silverado 1500. Last year in the spring, it randomly cut off. After a short time of looking around we realized the coil wire was exposed and shorting out on a line from the AC. Now all of a sudden after driving all fine all summer long, its started something similar I though. Upon driving, it randomly cut off one day at a stop, cranked right back up though. Then that afternoon, as I was driving home, it was as the engine was cutting off and on, as I was driving, applying gas, at random points in my drive, it would lose power for a second, and gain it back or lose power and regain in 2-3 short bursts. The next day, it cut off in the morning and wouldnt crank at all, after looking, a wire harness was against the same metal pipe for the AC and i notice it had melted the pipe of the wireharness slightly but the wires inside were fine, yet after moving the harness off the pipe and wrapping it with electrical tape the truck cranked right up. That worked for about a day, started again, I put a rubber hose around the metal pipe, that worked for about 2 days, then the problem came right back, cranking to leave work one day it was having trouble, finally after cranking, i raised the hood, and taped that very same wire harness with my finger and I heard the engine skip, but after that it wouldnt do it again. Anyhow, drove home, doing the power loss/gain again, I figured it would be fine till this weekend, wrong, it died again this morning and now refuses to crank at all. So my idea of those wires shorting out on the pipe are apparently wrong. Now, I am getting fire to my coil wire, yet not through it, it is not getting no fire at the other end. I bought a new coil wire, same problem still. A mechanic said it could be the crankshaft position sensor or the camshaft position sensor. I am stumped here on this. A friend said he believed the wires inside the harness could be shorting each other. So here I am stumped and asking for help, any ideas?

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 55 Answers

Yeah I would pull that harness apart remove the tape and the plastic conduit around it and really give the wires a good inspection to rule them out then your going to want to make sureto pit the plastic conduit back on there raping it if you want. And remember to check up the wires a good foot or so in both directions. Then make sure the rubber on that pipe can withstand temperature because it soulds like it's getting a little warm.

Posted on Oct 02, 2009

Testimonial: "Thanks I found the prob. The wire coming off the harness to the sensor the coil runs into, the place it plugs in was loose inside! Problem solved now!"

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 101 Answers

If u can start ur engine,do it at night to see if u can see an apparent spark in the area u are talking about, If not and it is not very expencive change out the sensor. U cluld take to ur nearest Autozone and hve them run a system check,usually it's free.

Posted on Oct 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

99 silverado 1500 4.3 engine won't start


check high tention coil wire, coil wire going to dist cap with test light, if test light light up, it good also check dist rotor, and if that good might be pick up coil , the module might be bad, let me know what happen Bob

Dec 25, 2012 | 2005 Chevrolet Silverado

1 Answer

4wheel drive won't work


First check the fuse located in fuse box under hood. The most common problem is in the push-button switch located in the dash. I am a 67 year old female and fixed my boyfriend's 4WD in under 1/2 hour last week-end. You can order a new switch on eBay for under $40.00. Adjust steering wheel to lowest position and pull shift lever all the way down. Remove dash bezel from around gauges and switch (it just pops loose). This takes a little time getting it off from around steering column, etc. Just be gentle and patient. Snap out old switch, unsnap wiring, replace with new switch, snap in, replace dash bezel and you're done! There is a video on uTube showing steps. His 4X4 works perfect now and I get to tease him Double benefit. This was on a 1999 Chevy Silverado 1500. Let me know how it goes. Good Luck! -Marilyn

Sep 27, 2012 | 1999 Chevrolet Silverado 1500

1 Answer

Horn not working when you press on the streeing wheel but will work on key pad for a chevy pickup 2005 year 1500


Check the horn button on the steering wheel if it has continuity or just short out the wires on the switch connections. If there is only one wire on the horn switch, short it to earth to see if the horn works that way. That will indicate if the horn switch is faulty.

May 16, 2011 | 1999 Chevrolet Silverado 1500

1 Answer

My 1999 Chevy Silverado randomly stalls when running The igntion switch has been replaced twice in the past month


SOUNDS LIKE A FUEL FLOW PROBLEM, START WITH THE FILTER(S) THEN LOOK AT THE FUEL PUMP. IF THAT DOESN'T WORK, LOOK AT ALL THE IGNITION COMPONETS, STARTING WITH THE DISTRIBUTOR

Oct 31, 2010 | 1999 Chevrolet Silverado 1500

1 Answer

Abs and brake lights come on all the time on my 1999 chevy silverado 1500 4 wheel drive


It sounds like a faulty sensor wire on one of the calipers, I'd check the front first because they move around more than the rear. If the brakes have been replaced, sometimes the sensor wires don't get instaaled right and they either don't make contact or they get broken, difficult to put in unless you have experince with the new brake systems.

Oct 19, 2010 | 1999 Chevrolet Silverado 1500

1 Answer

99 chevy 1500 5.7 missing on 3 4 6 replaced tp, map, wires cap rotor fuel filter spark plugs injectors cam and crank sensor


Not much else it could be you have renewed just about everything. How about the coil sets? How healthy do the sparks look? try swapping some the faulty cylinder coils around with those that are good and noting the shift in misfires. The coils get hot and suffer over time. I think if you examine the sparks from each plug in turn you will see big differences from good to poor. For safety disconnect the fuel pump relay when checking the spark we don't want any fires.

Sep 18, 2010 | 1999 Chevrolet Silverado 1500

2 Answers

I have a1997 chevy 1500 4.3 l will crank no spark new coil module good new timing chain help


Check your crank sensor down at the bottom right of your timing cover.
Make sure its connected, make sure its clean and doesn't have some metal shavings on it.

Mar 07, 2010 | 1999 Chevrolet Silverado 1500

1 Answer

Broken Chevy 88 Silverado shift indicator. Need diagram to see individual parts and how to fix it. Red indicator tab does not move when when changing gears. is there a spring in it? Cable?


The neddle is attached to the column via a thin metal wire and spring which then clips to the edge. Remove the trim above the column and look for the clip attached to the wire and a warn spot on the column and reattach it. :)

Oct 08, 2009 | 1999 Chevrolet Silverado 1500

4 Answers

5.3 L Missing and Rough Idle Intermittently


i have a 2001 chevy z-71 5.3L. I keep getting a random/multiple misfire code for cylinder 1 . I have replaced plugs, wires, coil pack(only on #1 cylinder)., and fuel pump. I still keep getting the cylinder 1 misfire code. I put truck on a scanner and watched the cylinders. # 1 misfires at idle but quickly stops misfiring at around 1000 rpms. you can here the engine miss at idle but truck runs great on road . anyone else ever had this problem?

May 05, 2009 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

230 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...