Question about 1996 Volvo 850

1 Answer

The rear speakers in my 1996 850 do not work. Is there an amp somewhere in the car? I can hear a little sound if I turn the volume al the way up. I replaced the stereo an have the same problem. Any help would be awsome!

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

  • Expert
  • 97 Answers

I have had to replace a good number of rear speakers in 850's. The car does not have an amp unless it is a R series.

Posted on Oct 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My sound stopped working except the sub and amp.


If you have a little electronic know how... it can be a blown capacitor in the speaker. If you find it, solder a new one in and turn the volume down in the future. And look around for any signs of burnt insulation. Trunk amps are notorious for being insufficiently wired for power.

Apr 24, 2015 | 1998 Nissan Maxima

2 Answers

Radio volume went out after a popping sound in the rear. It turns on and I can hear it but very faintly.


If power is more than speakers can handle this will happen. If you have a amplifier in the rear than all it is a fuse or a circuit breaker needs to be reset

Mar 25, 2015 | 2007 Jaguar X-Type

1 Answer

Radio on but no sound after installing after market subs


to create a spark you must have had power connected somewhere. Did you have your radio turned on when you connected? if yes you may have blown the amp in the radio. If no then you have other issues with wiring and possible damage.
It's one of those instances where I'd need to be there to diagnose it.
Start by double checking the stereo is working, check its wiring is correct try each speaker connection in turn. If the stereo works and all the outputs work then double check the amps wiring and try a normal speaker connected to it. You must get the picture by now, you need to identify the source of the fault. to help you better I'd need a wiring diagram.

Dec 20, 2011 | 2003 Toyota Camry

1 Answer

I turn the volume all the way up & it still sounds low,i even changed my speakers.


I have an acura legend 1994 and I'm having same problem, the volume will work correctly once in a while when it wants to, otherwise I have to turn the volume on high and not even get a good sound or can nearly hear anything. I wanna know why, is it a fuse? Or electrical?

Jul 12, 2011 | 1994 Acura Legend

2 Answers

I put in a cd player everythings connected but there is no sound coming out of the speakers


check your wiring, make sure its not grounded behind the dash somewhere

Sep 18, 2010 | 1993 Lexus Es 300

2 Answers

Front speakers only produce static


The amps are on each of the speakers. There is a place in Florida that will fix them for around $85.00 each plus shipping. I put a sony unit in mine and replaced all of the speakers with the kicker ds series for less than fixing the bose system.

May 29, 2009 | 1991 Cadillac Seville

1 Answer

Volume low on all four speakers, some static (amp or head unit problem)


I would check the amp first, especially if you have very low sound on the speakers. Before amps were made, bad output transistors would create the same effect.

Apr 13, 2009 | 1997 Chrysler Sebring

1 Answer

One speaker works all the time the others only sometimes


Could be intermittant wiring issue or the speaker itself.

If you have another spare car speaker you can hook up temporarily, I'd start there. Disconnect one of your "bad" speakers and hook up a known good one. If the temp. speaker works OK all the time, then you know you wiring is okay.

Let me know if more ?s!

Mar 22, 2009 | 1996 Chevrolet Cavalier

1 Answer

Driver side speakers crackling


BLOWN OUT SPEAKERS OR BAD WIRING

Jan 17, 2009 | 1997 Lexus LX 450

Not finding what you are looking for?
1996 Volvo 850 Logo

Related Topics:

176 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8522 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...