Question about 1999 Mercury Cougar

2 Answers

Why does my 99 mercury cougar shake when i come to a complete stop and accelerate over 55mph.

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 708 Answers

Tires could need balanced. However, my past experience says its because your rotors are warped. They need to be machined smooth again. Doing this requires new brake pads as well. Should just be the front causing the problem

Posted on Oct 01, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 157 Answers

If it shakes at a complete stop, it may need a motor mount or transmission mount. If the engine itself is not running smoothly, it may just need a tune up.

Posted on Oct 01, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Start


could be a motor mount or its not running on all cyclinders

Aug 23, 2014 | 1999 Mercury Cougar

1 Answer

99 mercury cougar idles rough and stalls on acceleration.


Possibly TPS sensor located on top of engine or leaking vacuum line

Apr 17, 2014 | 1999 Mercury Cougar

1 Answer

The engine light on my 96 merc cougar XR7 is on. Car shakes bad when i accelerate and engine light begins to blink. I'm embaressed to say my engine light has been on for sometime but was told it c


The check engine light needs to be addressed. Yes it could be a sensor but you need to know.
The light blinking means the problem is serious, such as a dead miss on one or more cylinders. The light being on means something is happening with the engine performance that could damage the catalytic converter.
Get the computer scanned - most auto parts stores will do it for free in hopes of selling you some parts. Once you have the codes research them online or here.

Sep 28, 2012 | 1996 Mercury Cougar XR7

1 Answer

99 Mercury cougar, the accelerator cable broke at the gas pedal how do i fix it? Do I need to replace the entire cable or just fix the part at the gas pedal?


replacing the cable would be the best thing to do it is hard to do on some models but depending on were it is broke and how much slack you have you could possibly get a cable connector for it like these
images?q=tbn:and9gcqfyo45jkcst_y-72ymudwhwtebag9vpseytoftptyd0-igfu2bkwspeaces

Sep 30, 2011 | 1999 Mercury Cougar

1 Answer

My 99 cougar had the transxale fix 8 moths ago but now it shakes badly and puls when reach 60 mph or more what could it be?


Sounds like a tire problem. Swap both front tires side to side and see if the pull goes to the other side.

Aug 30, 2011 | 1999 Mercury Cougar

1 Answer

99 Cougar Acceleration


It could be the MAF (mass air flow) sensor. Once the engine warms up it starts to use all of the sensors to operate the engine. Try unplugging the sensor to see if that restores some of your lost power.

Mar 04, 2010 | 1999 Mercury Cougar

1 Answer

99 mercury cougar


Rotten egg smell??? Thats smell could be either from a bad 02 senser or a totally clogged catalytic converter...not terribly expensive to replace. As far as the engine shaking, and it not going quick out of the stop light, I'd pull my tranny dipstick and smell the fluid and check for a buring smell and or the color. You want it to be a light red color. You may have an internal transmission issue. You said you got "fluild" out of your tailpipe, was it just water, or was did it have a scent to it. You really should have the car checked out, with those symptoms that you listed you could do more damage by still driving it that way.

Mar 26, 2009 | 1999 Mercury Cougar

1 Answer

Car stalling under acceleration


bad fuel pump it i about to go out but hasnt gone completely out yet

Oct 06, 2008 | 1994 Mercury Cougar

Not finding what you are looking for?
1999 Mercury Cougar Logo

Related Topics:

330 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

fordexpert

Level 3 Expert

5520 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...