Question about 2000 GMC Yukon Denali

1 Answer

2000 denali seems to idle high at a complete stop, wants to"go" but gauges dont move while doing this?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 104 Answers

You may have an intake leak (vacuum leak) somewhere or ldle contol motor gummed up or mass air flow sensor has dirt build up on the front of the resistors

Posted on Oct 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 GMC Yukon Denali


Check for trouble codes. You can get this done free at most car part stores.

Aug 16, 2014 | GMC Yukon Denali Cars & Trucks

1 Answer

Battery indicator light comes on above idle RPM, gauges start fluctuating.


The first thing you need to know is what the alternator output is when this starts happening.
It could be a faulty connection in the wiring harness, or a bad ground connection, or a failing alternator.

Aug 25, 2012 | 2000 Mercury Cougar

2 Answers

Having issues with a 2000 chevy impala overheating have changed the radiator and the thermostat fans seem to be working ok but overheats at idle in stop and go traffic, after a certain amount of time it...


YOU NEED BLEED COOLANT SYSTEM.CHECK COOLANT LEVEL IN RADIATOR.ADD MORE DEXCOOL UNTIL COOLANT LEVEL IS CLOSE TO RADIATOR SPOUT.CRANK ENGINE LET IDLE UNTIL TOP RADIATOR HOSE GET HOT.WATCH TEMPERATURE GAUGE.IF TEMPERATURE GAUGE START RISING TO HOT ZONE.TURN OFF ENGINE.LET COOL DOWN.USE LARGE RAG SLOWLY OPEN RADIATOR CAP A LITTLE AT A TIME UNTIL ALL PRESSURE RELIEVED.REMOVE RADIATOR CAP.ADD MORE COOLANT.CRANK CAR AGAIN LET IDLE UNTIL TOP RADIATOR GET HOT.KEEP EYE ON TEMP.GAUGE ALSO.WHEN TEMP.GAUGE STOP CLIMBING.YOUR COOLANT SYSTEM BLED.WHEN DONE LET CAR SET A WHILE CHECK COOLANT LEVEL.ALSO FIRST THING IN THE MORNING CHECK COOLANT LEVEL AGAIN.AND BESURE ADD COOLANT IN THE OVERFLOW JUG TO THE COLD MARK.DONT OVER FILL THE COOLANT RESERVOIR JUG.WORK SAFELY DONT GET SCALDED.

Feb 15, 2011 | 2000 Chevrolet Impala

1 Answer

Hey Chevy Minivan heater dont work properly


Chevy made some weak intake gaskets on 3.1 and 3.4. My guess is that the intake gasket is weak and/or leaking and it is letting pressure out somewhere. At idle maybe the system pressure is to little to push hot coolant into the heater core.

Dec 21, 2009 | 2000 Chevrolet Venture

2 Answers

2006 Yukon Denali, oil pressure gauge malfunction


Most likely the oil pressure sensor is bad. Its located in the very rear of engine on top of bell housing area.

Oct 30, 2009 | 2006 GMC Yukon Denali

1 Answer

2000 Yukon Denali high idle? no check engine light on? Were do i look for the problem at?


it can be adjusted at the cable end on engine could be the computer doing it to.

Oct 01, 2009 | 2000 GMC Yukon Denali

1 Answer

Fuel gauge erratic


you will need to have the cluster (guages) repaired or replaced. (for the vibration). You will need to do this first.

They also have problems with the fuel level sensor in the tank, the contacts corrode and will give false readings. BUT this will not cause the guage to vibrate as you have described.

Aug 04, 2009 | 2000 GMC Denali

2 Answers

Vehicle overheating when in the idle position. When I stop the vehicle at a light or the vehicle is idling the thermometer gage is going up very high. When I drive it seems to cool off abit.


Your cars thermostat needs replaced it is stuck closed. to test this wen stopped engine running lower windows turn heat on blower to high if your temp gauge lowers in temp have it fixed ASAP. Not much money unless you wait till your engine overheats then BIG BUCKS

Jul 11, 2009 | 2000 Oldsmobile Silhouette

1 Answer

Temp gauge goes into RED at 3000 revs and/or under load/acceler..


sounds more like a weak spring in the thermostat....not keeping the thermostat open fully under high water flow (like in higher rpms)

Feb 22, 2009 | 2000 Ford Focus

1 Answer

Idles high while driving


Could this be the fan clutch making it seem to idle high? Does it calm down after a short distance of driving? Watch RPM gauge to see if it is actually high revving or just noise?

Jan 10, 2009 | 2000 Ford Ranger SuperCab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

116 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...