Question about 1999 Chevrolet Venture

1 Answer

JUST PUT IN A NEW BATTERY, WORKED FINE. SAT IN MY CAR LISTENING TO MUSIC AND TURNED THE VAN ON AGAIN AND EVERYTHING TURNED OFF, NOTHING IS WORKING AT ALL. WHAT WENT WRONG?

Posted by on

  • barrywhook May 11, 2010

    turn indicators and hazard lights not working on my 2001 jeep grand cherokee. having a real job identifing any relays on this circuit or could it be the actual indicator arm?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 198 Answers

Altenator may not be charging battery.Have the altenator tested.

Posted on Oct 01, 2009

Testimonial: "Thank you for your help. A friend of mine said the same thing, but I just wanted to make sure so that is why I wrote to you guys. Good work!!"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 2000 e350 box truck it sat for a while with no battery in just bought new battery and put in. Radio worked pumped gas and turned key and everything went dead no crank nothing what could it be?


Hi Allen:
The first thing that I would check would be the battery.
- Fully charged
- correct terminals
- clamps for corrosion inside
- wires

Mar 24, 2016 | Cars & Trucks

2 Answers

Van wont turn over not a sound i put in a new battery


if it works jumping it then the starter is fine. check fusible links to see if one is blown. check all contacts, engine grounds too, for corrosion and clean if necessary.

Sep 16, 2012 | 1995 Toyota Previa

1 Answer

Why have i lost all electrical power to my 1974 dodge tradesman van


With the battery connected, did you check the fuseable link which is the pigtail wire on the positive cable ?
If nothing works, it has to be a bad cable, bad connection, or one of the major fuseable links from the battery to the fuse box.

Aug 04, 2012 | Dodge Cars & Trucks

1 Answer

04 Pontian Montana DVD, dead battery


sound like a fault in dvd player.its running battery down.have dealership check it out.sound like a electrical problem.

Jan 03, 2010 | 2004 Pontiac Montana

1 Answer

2004 BMW X5 4.4i Left lights on resulting in flat battery. Car was jump started from another vehicle (Ford Transit van). Everything fine for a few days. Now, intermittently the radio/sat nav goes haywire!...


sounds like your car has the multi function steering wheel, i know on the 7 and 5 series they come out of sync, im not sure why.
its about £75 to get plugged in at the dealers and they reprogram it, sometimes i have had the odd car with a damaged slip ring, it does all sorts of things, 1 in particular kept on beeping the horn,
i would say if u got 1 urs got upset when battery flat.

Apr 22, 2009 | 2009 BMW X5

2 Answers

93 LX 5.0 replaced battery, ran fine then would not start


sounds like you have a good battery, get the car started put a voltmeter to wire connected to the back of your alternator. if you have at least 13.25 volts you have a good unit if any lower replace the alternator
the click sound you are hearing comes from your relay it is getting low voltage from the battery. because the battery has no juice caused by a bad alternator


hope to help shack

Apr 15, 2009 | 1993 Ford Mustang

1 Answer

Silhouette will not start, but battery put out 12+ volts


You better have the alterntor checked, you said the battery was putting out 12v. was that with the car running or off? If it was running, it should have pushing between 14 and 15 volts, if it wasn't with it running, replace alternator.

Jan 30, 2009 | 2000 Oldsmobile Silhouette

Not finding what you are looking for?
1999 Chevrolet Venture Logo

Related Topics:

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6924 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...