Question about 2003 GMC Yukon XL

1 Answer

2003 Yukon, rough idle, extreme power loss,code PO300, miss firing. Changed plugs,wires, and fuel filter with no change.?????

Posted by on

  • Anonymous Mar 17, 2014

    missing and making a pinging noise noise goes a way when you pull number 2 plug

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

My brother had a similar issue with his Ford F-150, he needed the fuel injectors replaced. Good Luck!

Posted on Sep 30, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1997 saturn sw2 that stopped runnuing changed fuel pump wont idle error code #4 cylinder is miss fireing changed ignition module car starts runs ruff changed spark plugs & wire set


You need to make sure the cylinder is getting fuel and that it doesn't have a vacuum leak at the intake that is leaning it out and causing a misfire, if that checks ok then determine if the #4 cylinder has acceptable compression as compared to the other three, all cylinders should been within 5% of the cylinder with the highest pressure on test.

Mar 03, 2017 | Saturn SW2 Cars & Trucks

1 Answer

1996 MERC 220 HAS ROUGH IDLE AND POWER LOSS ON


Coils, wires, plugs, fuel filter. A real tune up in other words.

Apr 05, 2010 | 1996 Mercedes-Benz C-Class

1 Answer

My Expedition is idleing extremely rough. I just changed the spark plugs, fuel filter and air filter and no codes are coming up. It has 97000 miles and had maintained proper maintenance. Any ideas???


Was it doing this before you changed the plugs? This is coil over plugs correct? Double check you pugs and if it is coil over be sure to use die-eletric grease on the spark plug boots. Good Luck

Aug 04, 2009 | 2003 Ford Expedition

1 Answer

2003 yukon xl 5.3l flexfuel all plugs lean on passenger side


P0131 - Heated Oxygen Sensor (HO2S) Circuit Low Voltage

P1133 - Heated Oxygen Sensor (HO2S) Insufficient Switching Bank 1 Sensor 1


Bank 1 Sensor 1
P0300 - Engine Misfire Detected

I would check for vacuum leaks, maybe intake or brake booster

Dec 16, 2008 | 2003 GMC Yukon XL

Not finding what you are looking for?
2003 GMC Yukon XL Logo

513 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...