Question about 1999 Oldsmobile Bravada

1 Answer

2000 Bravada 4.3l hard start when cold but then runs and starts fine after that. Fuel pump pressure is at 53psi. Spec is 60-66psi. Is this the problem? I have changed the coolent temp sensor and the cap and rotor.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Yes it is

Posted on Sep 29, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

99 express hard start when cold


First thing is to check the fuel pressure regulator it could be faulty then i would check the fuel pressure it should be 60-66 psi with the key on and engine off.If its below 54 psi i would replace it.

Jan 15, 2012 | 2000 Chevrolet Express Cargo

1 Answer

Car runs great but on a cold start it has a rough idle like a bad plug or fuel filter replaced both after car is warn will start fine every time


has the engine coolant temperature sensor been checked to see that it has the correct ouput votage at the chart temps, if it is out of spec the engine can run lean and this would cause cold start issues, also what is the fuel pressure reading when key is shut off, does it drop rapidly? should never loose more than 5 PSI, if it does the fuel pump is defective, also a fuel filter will not cause hard start or rough idle, only overall loose of power, does it have that at anytime?

Oct 27, 2010 | 2004 Lincoln LS

1 Answer

I have a Silverado 1500, 4.3 with 132,000 miles. After start, it runs fine, no signs of malfuntion. However it takes extended cranking to start. The fuel pump & filter was replaced 10,000 miles ago....


You need 3 things.
Compression
Good hot blue spark to all plugs.
Good gasoline and proper fuel pressure. 63-64 lbs.
If you have all 3 then move on to injector pulse to all injectors.

You may be weak on fuel pressure . even a couple of lbs low on a cold start will cause a no start. Double check cold start cranking fuel pressure. If under 63-62 lbs you have problems. One test is to give it a squirt of carb cleaner not starting fluid. If it starts then you have a fuel pressure problem. Run the full fuel pressure test and post back pressures. Here is the guide lines on testing.
Hard to start cold.
Check cold start fuel pressure.
Check engine running fuel pressure.
Check engine running on the road fuel pressure.
Then shut it off and watch for fast leak down.
Pinch off at rubber part or block off return line and check full pressure.
Later V6 and V8 gm engines should have 60-66 fuel pressure.
Cold start should be 64-65 lbs of pressure.
If you do not have full fuel pressure on a cold start the injectors will not squirt fuel.
Do not leave home without it.
Engine running should be 60-66 lbs pressure depending on engine load.
Full pressure with return pinched off should be 75-85 or more.
And if it has a fast leak down after shut off you have a leak.

Also you mentioned that you replaced the fuel pump, it's common for the $15.00 wire harness from the fuel pump to the frame will break and there is a bad connection till the wires heat up. You can try this trick, turn your ignition on for 30 seconds "engine not running" and then turn it off for for 5 seconds and then try to start. This will energize the fuel line if the fuel line check valve is bad which is a part of the fuel pump and will heat up the wire harness which will make a better connection and see if the engine starts easier. Regardless, inspect the wire harness for corrosion and the ground is good. Good luck and keep me posted.

Dec 15, 2009 | 2000 Chevrolet Silverado 1500

1 Answer

I am having problems starting my 2000 Olds Bravada in cold weather, even only 11-20 degrees. I have to pump the gas pedal in order for the vehicle to start, after a few tries. I can hear the pump working...


The pump is supposed to stop when the fuel rail has enough pressure so the 5 sec. thing is normal.Sounds like you need a throttle position senser replacement.

Dec 14, 2009 | 2000 Oldsmobile Bravada

1 Answer

My 2000 s500 won't start in cold winter season. i


Malfunctioning fuel system.
Fuel injector[s] leaking...check fuel pressure,more then 53psi
check fuel injector resistance / ohms/
Ignition component damp or demaged.Checks wires broken,loose or disconnected in the starting circuit.Worn, faulty spark plugs.....

Dec 12, 2009 | 2000 Mercedes-Benz S-Class

1 Answer

Will not start without a shot of startig fluid.


ther may be a cold start valve or injector not working

Jul 07, 2009 | 2000 Oldsmobile Bravada

1 Answer

Hi, I have a 2000 Bravada That i have to turn over and pump the gas several times before it starts. Then it runs fine. If I shut it off it will fire right back up if turned on again. However if I wait any...


Your problem is the fuel pump pressure check valve is defective, this is part of the fuel pump and the fuel pump is located in the fuel tank. Have the fuel pump replaced.

Jun 10, 2009 | 2000 Oldsmobile Bravada

1 Answer

Engine starts but it run rough


do a pressure test on the fuel pump. if that tests ok then check your sensors. is it shooting a code (service engine light)? Oxygen sensor at back of cat. converter, crank shaft sensor or throttle position sensor. Unfortunately sensors are hard to trace. These are the suggestions I recd. for my bravada. it idles great but dies about every 1000 feet or so while driving. cut it off and re-crank and go another 1000-2000 ft. and do it again, will start running rough until you kill the ignition and restart the truck. pretty sure mine is a weak fuel pump.

Aug 09, 2008 | 1999 Oldsmobile Bravada

Not finding what you are looking for?
1999 Oldsmobile Bravada Logo

324 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...