Question about 1985 Jeep Cherokee

1 Answer

Electrical issue with instument lights

With lighton when i give a signal my gas guage goes to e and my amp,temp guages fip back nforth.no instument ligs n both turn signal indicator lights flicker.

Posted by on

1 Answer

Maybe a loose ground somewhere

Posted on Sep 28, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

96 ford explorer battery light on volt guage high then lights blink and drops to normal and batt light goes off for a few seconds then it does it again but it does not die. Whats wrong?


Sounds like you may have a voltage regulator going bad in your alternator. They will usually check them for free at chain parts stores. Probably won't even have to take it off the vehicle.

Jun 03, 2016 | 1996 Ford Explorer

2 Answers

2000 Pontiac Grand Prix GT...issue is with my gas guage, it "floats" instead of giving an accurate reading. It floats from full to empty and back, never settling on the actual fuel level. Is the...


Welcome Pontiac familyProblms and Problems, fuel level I think is not worthy of fixing, go with 300 km or 200M. then refill.Broken or ***** ABC wires.

Jun 11, 2017 | 2000 Pontiac Grand Prix

2 Answers

Peugeot Expert Van- Erratic temp guage & 'STOP' dashwarning light


temperature sender unit top of engine cylinder head make sure its okay
and make sure wire going to it is not grounding
if it grounds or earths it will send the gauge up and down

Feb 22, 2010 | Peugeot Liberte Cars & Trucks

1 Answer

Turn signal, tachometer, fuel and temp guage stopped working


you should pull out the gauge cluster and check the connector on the back side of the cluster.. i bet that is the issue

Jul 18, 2009 | 1989 Honda Accord 4 Door

2 Answers

All my guages went out at the same time...windows


sounds like alot of problems, have rolled into 1, without looking at it with my eyes, could be the main electric box that has just packed in

Jun 05, 2009 | 1997 Honda Accord

1 Answer

1999 blazer guages not working


It sounds like the wire harness in the back of the instument cluster has gone lose. Check the wire harness. Good luck

Apr 06, 2009 | 1999 Chevrolet Blazer

1 Answer

1999 Pontiac Grand Am Fuel Problems


The gas guage has a sending unit in the tank attached to the pump, there is a small circuit board on it that has smal"fingers" that send the signal to the guage.These get worn off and thus sends a false reading to the gas guage in the dash. The gas tank must be removed and a new unit put in to solve the problem. I had to do this repair to mine. As for the gas issue, just try pulling the nozzle back out of the filler neck when putting gas in, sometimes the overflow tube gets plugged up and won't allow the air to escape as the gas goes in the tank, making the gas pump think the car is full, pulling the nozzle will allow the air to escape. Hope this helps.

Mar 08, 2009 | 1999 Pontiac Grand Am GT

1 Answer

Instrument panel guages don't read accuratly


I have a chevy cav 03 and my problem is just in the gas guage and temp guage now i cant seem to figure out how to fix it but for a quick fix i have jut been pulling out the instrument panel fuse and putting it back in it seems to fix t

Feb 26, 2009 | 2000 Chevrolet Cavalier

1 Answer

Instument Guages


well the issue is youe enitre gauge cluster i do understand that your speedometer is working but it is a cable speedometer not electronic like everything else in the gauge cluster so first i would recomend checking the voltage getting to your gauge cluster then just replace the guagecluster they are really cheap i a salvage and not hard to install at all but the cluster itself is not very comon to go out so make sure you check voltage to it first i wouldnt want you to go through buying and replaceing the cluster and that not fix it

Jan 20, 2009 | 1991 Mitsubishi Eclipse

1 Answer

Temp guage goes to max (right) when engine is cold.


change the themostat when you remove the old themostat you should see it stuck in the open postion . before i install the new one i fill the the block with coolant install the new stat run the mtr and heater core until hot iwould also replace the cap

Jan 01, 2009 | 2001 Dodge Ram 1500 Truck 2WD

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

126 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...