Question about 1996 Isuzu Hombre

Open Question

It starts and goes but when I get somewhere and shut it off, it wont start again. If I leave it and go back later, it starts.

Posted by on

  • 1 more comment 
  • csanchez53 Sep 28, 2009

    It cranks but doesnt start. Have checked fuel filter.

  • csanchez53 Sep 28, 2009

    It cranks but doesnt start. have checked battery and fuel filter.

  • Slatrom May 11, 2010

    Will it crank, or does it crank but not start?

×

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Shuts off after start up


You need to have the ECU checked for any codes.

Oct 26, 2013 | Mazda MX-5 Miata Cars & Trucks

1 Answer

My 2005 Suzuki forenza starts sometimes and goes but then if you shut it off it wont start again for a while..why is that?


Check your spark plugs first.
second replace spark plug wires
check coil pack. Most of the times a engine light will be on.

Mar 19, 2013 | 2005 Suzuki Forenza

1 Answer

Car ran fine drove it twenty min went to start it again wouldnt start went back an hour later started right up drove it 15 min and it died again changed the plugs and fuel filter still wont start


This sounds more like a crankshaft position sensor. When they start going bad they will work when vehicle relatively cold but fail when hot.

Hope this helps, it it does please leave feedback and vote Thank You and Good Luck

Jan 02, 2011 | Nissan Altima Cars & Trucks

1 Answer

I have 97 camaro it starts and drive fine but when i shut it off it wont start back up until it sits for a few hours?


We had a problem like this in our 97 Camaro with the V6. It would run fine until my wife went somewhere with it, parked it and then wouldn't restart. When it would sit for about an hour then it would start again. It turned out to be the crank position sensor, when the electronic part of it got hot enough it couldn't sense correctly and tell the computer how to time the spark. All it would do is crank without firing. So once we had that sensor replaced it ran good again. Good luck I hope this helps! I'm on to the next problem it's having, an occasional battery drain and a radio and electric windows that die when they want to and come back later. BuzzieTN

Sep 16, 2010 | 1997 Chevrolet Camaro

2 Answers

95 dodge Neon. Crank but wont start. I Changed the coil pack and the car started right up. 3 days later I started the car and shut it off, started and shut off, and then the car would not start again. It...


had same problem. neons are bad for the gas filler tube rusting out. there has to be pressure in the tank for the car to run.check and see if yours is rusted out or hole in it somewhere.

Mar 30, 2010 | 1995 Dodge Neon

3 Answers

I have a 1990bmw 325i. i turned the car off one day. ran in the store. ten minutes later came out and the car wouldnt start. left the car. came back thirty minutes later the car started. drove the car 25...


Car not starting or turning over indicates towards multiple possibilities. It can be issue with battery or weak battery. But if battery checks out ok, then it can be starter issue or faulty alternator or problem with low fuel pressure or no spark at spark plugs due to dirty spark plugs or faulty ignition coil or injectors getting cracked or dirty and needs to be cleaned.


To confirm the problem, the basic troubleshooting is required.


Click this link below and follow the troubleshooting:------

http://technoanswers.blogspot.in/2012/02/car-starting-issues.html

---------

This will help.

Thanks.

Dec 14, 2009 | 1990 BMW 3 Series

1 Answer

1987 gmc jimmy wont start


yea you have no fuel and sound like a bad harness and the gm's are know for there fuel pump harness's! did you change it when you changed the pump? there is a lose connection somewhere in the fuel delivery system and it's pretty simply! i would check the fuel pump relay on the left hand side of the engine compartment and maybe even put power to the pump at the relay position "b" on the fuel pump relay harness and there should be a one pin connector to put power to also connected to the same position on the relay "b" the wire should be tan and white! good luck

Sep 18, 2009 | 1987 GMC Jimmy

1 Answer

Electrical. wont re-start unless cold.


You probably have some corrosion on your battery terminals. Make sure they are clean and connected good and tight.

May 04, 2009 | 1997 Volkswagen Jetta

2 Answers

1991 supra


is it a stock alarm.

Jun 21, 2008 | 1991 Toyota Supra

Not finding what you are looking for?
1996 Isuzu Hombre Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14398 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...