Question about 1988 Chevrolet Corvette

1 Answer

1988 corvette: hard starting,missing,boggy underpower.These problems just started after a 2hour drive.The temp is holding around 200-225.I added a bottel of Lucus fuel treatment and it seemed to help a little any ideas?

Posted by on

  • 1 more comment 
  • jroetech Sep 27, 2009

    I will today, Thanks

  • Psloan May 11, 2010

    having to push hard on the brakes to get them to work. Can you advise the issue?

  • Danny Rey May 11, 2010

    Have you checked your spark plugs?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 6,982 Answers

Sounds like a bad EGR valve or a plugged catalytic converter. I'm not there or I may have a different opinion but that's where I'd look first.
Good luck

Posted on Sep 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Gas shoots out from muffler and car runs like it miss just started all of a sudden on a 1988 corvette


Check spark plug wires and spark at each cylinder.

One can check with an inductive timing light on each spark plug wire to see if spark is available at each cylinder.

Aug 10, 2010 | 1988 Chevrolet Corvette

1 Answer

90 corvette with 22,000 miles running very rough and back firing


Well it sounds like you've started to do your "due diligence", but there are several things left out. Your problem could be many things. Something as minor as a vacuum hose left off, loose, or in the wrong place. And just because you changed the plugs and wires, don't mean you fixed your problem. Open your hood at night and see if you have any sparks "dancing" around. Another way to check this is to open your hood and spray a soapy water solution on your plug wires and look for sparks jumping around. If so replace your wires. You didn't mention what type of wires and plugs you used. I would reccommend NKG platnum plugs and a Bosch wire. I know this from experience,(the hard way teacher). It could even be the gas you are burning. I've owned a lot of Vettes, and I am the kind of guy who believes they should be driven. If not it's like having a beatiful wife and never taking her to bed.I know a lot of people who only drive them "once in awhile". Sitting in thier garage can cause many fuel problems, condensation, sludge in the carb, or filters etc. This can all lead to the problem you are describing.
Low speed miss- usually plugs
High speed miss- usually wires or valves
intermitten miss, fuel or electrical.
I hope I gave you some places to look to find your problem.


Jul 07, 2009 | 1990 Chevrolet Corvette

1 Answer

I have a 1995 ford windstar that seems to have a temp. problem. While driving the temp. gauge goes all the way to HOT. The van never overheats but the A/C will eventually start blowing warm air. I flushed...


oddly enough it sounds like a transmission problem, get a transmission shop to assess the problem, but first try replacing the thermostat. be sure to turn on the heater when adding antifreeze. I have had this problem with my windstar.

Jun 26, 2009 | 1995 Ford Windstar

6 Answers

1989 Corvette starting and idle problems


replace the coolant temp sensor, not the coolant temp sending unit

Jun 05, 2009 | 1989 Chevrolet Corvette

1 Answer

1988 Corvette Bose Radio Front Speakers only work periodically


try different speaker if works .its the speaker. if another speaker does the same .your radio is the problem.

May 01, 2009 | 1988 Chevrolet Corvette

1 Answer

1988 Corvette Hot Start problem


those 88 tpi engines had an injector bulletin but very few ppl were ever told so i would have fuel system tested but my 88 350 had bad injectors manufactoring defect they would leak too much fuel in into cylinders

Jun 12, 2008 | 1988 Chevrolet Corvette

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

257 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...