Question about 2000 Chevrolet Blazer

1 Answer

Runs ruff stumbles when first start then clears up within 1/4 mile. sometimes fires then stalls. but after setting few minutes starts and runs?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 750 Answers

Check fuel system and filter and ignition system

Posted on Sep 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car stalls after driving about a mile. but starts back up after a few minutes.


Check your temperature that it's not over heating and if not check your 02 sensors which are for when car starts stumbling and turns off.

Mar 15, 2016 | 1998 Lincoln Town Car

1 Answer

Truck starts runs for a few minutes then stalls sometimes starts again sometimes wont start


Can either be fuel filter is dirty or fuel pump is going and there may be a short or burnt wire on the fuel relay. they should all be located in the same area.

Feb 29, 2016 | Cars & Trucks

1 Answer

Intermittent stalling


Two - from experience
1. Your fuel filter is 98% clogged - something sloshes around and it goes to 100% clogged and your stop. When you stop, that last 2% falls to the bottom of the filter. You fire it up and get going - repeat.
2. Your coil pack is bad and or the wires. The coil gets hot - plastic expands - begins to arc - and you stop

1 is more likely I think, especially if the service engine light is not on.

Apr 13, 2013 | 1984 Volvo 240 Series

1 Answer

1989 lesabre stumbles and dies


I agree it sounds like the magnet for the cam sensor, or a problem in the wiring harness.
I don't think the engine will run with the cam sensor disconnected since it needs that signal to set base timing. It can run without the crank sensor once the engine starts.
There is a slight chance the timing chain is getting loose and affecting cam timing too. You may be loosing plastic teeth on the cam gear.

Apr 08, 2013 | Buick LeSabre Cars & Trucks

1 Answer

Pontiac Aztek 2001 - 3.4l (non-GT); Codes: P0135, P0141, P0420 all O2 + Converter. Ideas on problem?


P0135 bank 1 sensor 1 open or short in wires,bad connections,bad sensor ,or bad ecm. P0141 bank 1 sensor 2 same diag as P0135. P0420 cat below threshold open or short, or faulty Ho2s sensors.you may have several problems. start with sensors circuit if good change sensors if not trace to ecm if reading not right replace ecm if all good replace sensors clear codes retest drive two drive cycles for cat to clear tests. then with no dtcs present test fuel pressure , injectors,then ignition system ,timing valves ,map,maf sensors,throttle sensor,crank sensor cam sensor, compression.

Aug 02, 2012 | 2001 Pontiac Aztek

1 Answer

94 Bravada that stumbles and stalls.. won't start when warm..


Try checking the exhaust flow when someone else is pushing down on the gas petal.The farther the petal gos down,the more exhaust should be coming out. I replaced my catalitic convertor at 44000 miles, it was clogged. I had them install a high flow type.

Sep 03, 2009 | 1994 Oldsmobile Bravada

2 Answers

1991 deville idling very ruff


Hi you should change the coolant temp sensor this is a white sensor on top of the intake and is part ot the computer system.

Dec 30, 2008 | 1991 Cadillac DeVille

Not finding what you are looking for?
2000 Chevrolet Blazer Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...