Question about 2008 Chevrolet Tahoe

1 Answer

We just purchased an 08 tahoe with 11,000 miles. When you turn the ignition off and then back on the dvd player starts back at the beginning. Is this normal? thanks

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 439 Answers

Yes, while there are a few dvd players that keep memory with power off, GM protects the computer and battery by keeping other essential memory functions only. This includes powering the onstar system, keeping radio memory, holding enough charge for any alarm and remote door unlock, computer memory etc.

Posted on Sep 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 08 tahoe and it turns off running


It's not reading the chip,in the key,,,,,get new ignition switch with key,,,

Mar 13, 2014 | 2008 Chevrolet Tahoe

1 Answer

Cold weather starting problem


I would say it's bad contacts in the ignition switch. Metals change dimensions depending on temperature, looks like 45 degrees is the trick point for whatever is in there. My 04 Silverado 5.3 with 196,000 has the ticking, but it is gone within 10-15 seconds.

Mar 10, 2017 | 2001 Chevrolet Silverado

2 Answers

No Bus 08 dodge avenger..windows,radio,heater...etc..no start..disconnect battery..now its running again


Just bought a 2013 dodge avenger, literally yesterday. Test drove fine twice,, drove all over town for license and registration, multiple erands. No problems. I got to work and went to leave for lunch and was introduced to the no bus code. Left me stranded the very day i purchased it,, only 25000 miles. Is this problem simple enough to weather or is this the brightest red flag to take it back?

Jan 21, 2012 | Cars & Trucks

1 Answer

My ignition light on my 08 tahoe z71 is on and i got no problem everythng is okai with me so how do i turn it back off !!


Chances are that everything is not fine.
To turn off the light disconnect the battery for 3 minutes
re connect it the light should be off.
If it comes back on there is a problem.
You can go to Auto Zone and they will diagnose the
problem for free. The light has to be on for the problem to
be analyzed.

May 31, 2011 | 2008 Chevrolet Tahoe

1 Answer

I have a 2006 honda 2000 with only 11,000 miles - I do all my services and I just took it in for a old change - early because I have not used it much. The dealer says its time to change all my fluids every...


Change the engine oil and call it a day. Your owners manual has service intervals listed, and with 11,000 miles, the only fluid I would pay attention to is the engine oil at this time.

Apr 08, 2010 | 2004 Honda S2000

2 Answers

I just had the oil changed in my 2002 Tahoe but the ''change engine oil'' light keeps coming on. How do I turn it off?


Turn the ignition to the on position so dash lights come on, but do not start. Now pump the accelerator pedal three times quickly. The light will go off for another 3,000 miles

Jan 23, 2010 | 2002 Chevrolet Tahoe

4 Answers

Yukon dvd player will not continue playing on rear screen


Did you ever get an answer? I have the same problem on my 2007. The dealer told me it's a design flaw and that's how it's supposed to work.

Nov 16, 2009 | 2007 GMC Yukon Denali

1 Answer

Smelling antifreeze,i hear maybe waterpump,engine lightly sprayed on top in front of fan, engine runs rough when idleing but runs great at normal riding speeds running like this since august 08, when...


Could be a hose or the water pump either way when it leaks your fan is blowing the coolent back on your engine and could be blowing on your ignition wires making them wet and causing a miss fire. Do you have to add coolent regulary?

Mar 29, 2009 | 1992 Toyota 4Runner

2 Answers

97 tahoe mis


This starting issue sounds like either the ignition timing is way off, or the cam timing is, the whinning sounds like the timing chain may have been replaced with a non silent type chain (plastic cam gear teeth), maybe the onwer got this wrong when he installed it and the cam timing is off.

Nov 11, 2008 | 1997 Chevrolet Tahoe

Not finding what you are looking for?
Cars & Trucks Logo

155 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...