Question about 1997 Chevrolet Astro

1 Answer

My instrument cluster does not work, but when I put on the OBD2 Everything works

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 55 Answers

Bad circuit board behind thhe ckuster replace tgat printed board and you ar back in luck

Posted on Sep 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer fuse 2003 buick regal


No fuse just for the speedometer , fuse for whole instrument cluster . No reset either , hooking up a factory scan tool to check for DTC's - diagnostic trouble codes in the instrument cluster or BCM - body control module . Could be a bad stepper motor in the instrument cluster . GM vehicles from 2003 to 2006 had bad stepper motors .
How to repair GM Instrument Cluster Speedometer Gauge Stepper

Oct 13, 2017 | Buick Cars & Trucks

1 Answer

Does the 98 Ford F-150 5.4 triton have two coolant sending units? I found the one on the intake and replaced it and still no gauge.


Has CHT - cylinder head temp. sensor . This sensor is a input to the PCM - engine computer . The PCM sends engine temp info on serial data network to the instrument cluster . I/C has a microprocessor inside . Have it check for DTC'S - diagnostic trouble codes . Not OBD2 codes , B - body codes . The gauge could be the problem , which means replacing the instrument cluster .
Engine coolant temperature information is received by the instrument cluster from the PCM over the SCP network. Temperatures over 121°C (275°F) will display hot (H). If the engine coolant temperature data is missing or invalid for five seconds, the instrument cluster will move the engine coolant temperature gauge below the cold (C) position.
The best way to diagnose this is with a scan tool , factory or a professional type . Know how the system works and not replacing parts is the proper way to diagnose .
U1073 D073 SCP (J1850) Invalid or Missing Data for Engine Coolant PCM CARRY OUT the PCM self-test.
  • A single gauge does not return to zero with the ignition switch off
  • Instrument cluster.
  • INSTALL a new instrument cluster; REFER to Instrument Cluster . TEST the system for normal operation.

  • Incorrect temperature gauge indication
  • Circuitry.
  • Instrument cluster.
  • PCM.
  • Engine coolant temperature sensor.
  • GO to Pinpoint Test F .

I should also point out that if the temp sensor were bad the vehicle may not run right .
Using the factory scan tool
Trigger instrument cluster active command ENGCOOLNT. Monitor the engine coolant temperature gauge while adjusting the ENGCOOLNT active command to read 50% and 100%.
  • Does the temperature gauge start at cold, move to half at 50%, and full hot at 100%?
Yes REFER to the Powertrain Control/Emissions Diagnosis (PC/ED) manual.

No INSTALL a new instrument cluster; REFER to Instrument Cluster . REPAIR the circuit. CLEAR the DTCs. REPEAT the self-test.
Your best bet , take it to a qualified repair shop !

May 29, 2017 | Ford Cars & Trucks

1 Answer

1996 Ford Escort 1.6 Zetec, dash warning lights stay on dim even with ignition off. Light up normally when.ignition is on but no starter at-all. Plug in OBD11 tool and everything works fine


OBD11 tool and everything works fine ??? That'sjust for the engine computer ! Need a professional type scan tool to view instrument cluster data . The instrument cluster has a microprocessor inside an can set DTC'S - diagnostic trouble codes , separate from OBD2 . A bad cluster could bring down the Serial data network causing all kind of problems . Do you know what a data network is ? Your ford has SCP network .
Communications Network Information Module

Mar 27, 2017 | Ford Cars & Trucks

1 Answer

On a 2004 chevy tahoe. Once the instrument cluster wire clip is detached and new bulbs are soldered on the cluster. Does the instrument cluster have to be reprogrammed ?


Shouldn't need reprogramming. I removed the cluster from my 04 Silverado and sent it in for repair and replacement of the bulbs. It was out of my truck for 2 weeks. When I got it back everything worked just fine, no problems at all.

Jan 15, 2017 | 2004 Chevrolet Tahoe

1 Answer

Speedometer stopped working after fitting an alarm. What could be the problem?


Put everything back the way it was and see if speedometer starts working again?
Newer instrument clusters, the gages are not hardwired, The cluster receives buss data telling the instrument what to do with gages and speedometer. Checking the speedometer/vss sending unit would be a thought. Hopefully, you didn't hurt the instrument cluster?
What is year--make--model?

Apr 26, 2016 | Cars & Trucks

1 Answer

Instrument cluster is not working properly


Check for lose terminal pins at the instrument cluster connector . sounds like lose connection or lose ground wire !

Jun 18, 2015 | Cars & Trucks

1 Answer

Instrument cluster works intermediately. put another cluster in and changed starter switch and put on new cable ends on battery and still doesn't always work. What's the problem?


just a thought but does your dash have a dimmer switch?as you've changed the cluster and its still not right it could be that.

Jan 29, 2012 | 1998 Jeep Wrangler

1 Answer

2003 Jetta Tdi instrumentation cluster both LCD segments are no longer displayed Remove cluster and disassembled carefully removed displays and cleaned contact pads on circuit board and cleaned zebra...


Your LCD display is out of order. You can try to find one new on eBay. Chinese brand is cheaper, but VDO is better. After buying the LCD display you will need to install it.
See this link as an example of a new LCD display installation in the instrument cluster.
http://www.audizine.com/forum/showthread.php/263498-Official-DIY-2000-Audi-S4-LCD-Instrument-Cluster-Pixel-Repair

Aug 02, 2011 | Volkswagen Jetta Cars & Trucks

3 Answers

Speedometer and odometer not working


speedometer cable is bad, replace with new one

Aug 26, 2010 | 2000 Ford Taurus

1 Answer

Instrument panel lighting has stopped working.


Fuse on back of gage cluster, and the dimmer switch on the gage cluster.

Apr 24, 2010 | 1993 Mercedes-Benz 190

Not finding what you are looking for?
1997 Chevrolet Astro Logo

Related Topics:

134 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8531 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...