Question about 1999 Ford Windstar

1 Answer

1999 ford windstar speedo and tach going crazy jumping from one end too the otherefor about 30 seconds then after speedo works and tach does not

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 145 Answers

Its likely the VSS (Vehicle Speed Sensor) located at the back of the transaxle. needs replacement

Posted on Sep 30, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The instuments in the dash started going crazy, the tach gauge is stuck, what is the problem?


Stay out of the Burmuda triangle. :) (It's getting late 5:AM) check for a bad ground on the instrument cluster in the dash. Good luck. Jeff M.

Oct 19, 2014 | 2003 Ford Windstar

1 Answer

I have a 1999 5-speed ford escort zx2, while im driving my rpm will jump up and down all the way to 0 and stay at 0 for a second and jump back up and down, .


Tach spring is breaking, you can get a seperate tach gauge in place of what you got. or how about this take dash out and get another tach gauge they are removable

Apr 22, 2011 | Ford ZX2 Cars & Trucks

1 Answer

1999 ford windstar odometer doesnt work


If the odometer doesn't work, then you have a bad speedometer head assembly. The speedo head is a microprocessor that gathers the info coming from the vehicle speed sensor and translates it for you on the speedo and the odometer. If one is working, but the other isn't, then it is getting the VSS signal, it just isn't processing it right.
You have to replace the brake light switch(It would have been wet with brake fluid from having done brake jobs)

Apr 07, 2010 | 1999 Ford Windstar

1 Answer

Speedo and tach not workingin 1999 elentra


2000 elantra started shifting wierd now it jump in and out of gear when in drive, any thoughts

Sep 16, 2009 | 2000 Hyundai Elantra

1 Answer

1999 996 carrera speedo and tach does not work(analog and digital


maybe the speedo drive has stripped some teeth. good luck!

Jul 27, 2009 | Porsche 911 Cars & Trucks

2 Answers

Tach needle buried at park


Purchase a new keyless remote FOB. The signal from the remote is weak and loses contact with the anti-theft module in the instrument cluster. We have 2 sets of keys and 1 worked while the other caused the instrument cluster needles to jump and jam the gear selector. The problem is not the car's battery, alternator, wiring or instrument cluster.

Jul 16, 2009 | 2000 Ford Windstar

1 Answer

1999 windstar - fuse panel diagram


check the battery and check the altinator to make sure its charging correctly. your local advance or autozone store will do this for free. as far as the rear air coming on, I suspect the rear blower motor resistor

Jan 13, 2009 | 1999 Ford Windstar

1 Answer

Car won't start


I'd probably start with cleaning my connections at battery, & making sure my battery has a full charge. If not cured, maybe a new battery is required. If it will start with a jump, try running it for a couple of minutes with boosters on, and if all appears o.k. , change your battery.

Aug 21, 2008 | 2002 Dodge Neon

1 Answer

Gauges gone crazy


Could need new instrument panel cluster but check for corrosion as the instrument panel connector

Aug 11, 2008 | 2000 Ford Windstar

Not finding what you are looking for?
1999 Ford Windstar Logo

266 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...