Question about 2000 Mercury Mountaineer

1 Answer

Mountaineer won't start

I had to be jumped off about two or three days ago. Today the engine started making clicking noises and when I turned the engine off it wouldn't crank back up. Just makes clicking noises

Posted by on

  • Richard Scordino May 11, 2010

    sounds like you killed your alternator.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,865 Answers

You need to replace the battery

Posted on Sep 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 2001 mercury courage replace alternator 2wks ago ran great. Now today will not start. Tried to start and it would click when I turned key now won't do anything doesn't have any power....


Could quite possibly be you have a bad starter. I would have it tested. Could also be a bad battery. If, when jumping it, you used too high of a voltage, could have shorted out a wire somewhere

Oct 27, 2012 | Cars & Trucks

1 Answer

2005 Chevy Aveo, clicks but start won't catch and when jumped it doesn't charge what could it be??


Your alternator is not charging the Battery, I would replace the battery with a new gel battery and have the alternator checked, bets on your battery just died.

Apr 14, 2017 | 2005 Chevrolet Aveo Sedan

1 Answer

Factory alarm started acting up a few days ago, now car won't start. only hear single click noise. managed to jump started it once


Could be the battery is dead or dieing. When batteries start to go they will cause the security to act up. Plus other things

Aug 08, 2011 | 2006 Hyundai Tiburon

1 Answer

Factory alarm started acting up a few days ago, now car won't start. only hear single click noise. managed to jump started it once


The first thing i would do is to have the battery tested, most problems occur due to a weak battery so i would start by having the battery tested first you may have a low weak battery thats why you were able to jump start it . good day.

Aug 08, 2011 | Hyundai Tiburon Cars & Trucks

1 Answer

We bought a brand new battery one month ago. A few days ago, the car wouldn't start. We jumped it and it started. Today it won't start. When the key is turned, the car makes no noise. No clicking, no...


Check and clean the terminals then boost the car to start it after it starts. Well it's running take off the positive terminal if the car stops running the alternator is no good and you have to replace it.

Feb 07, 2011 | 1996 Volvo 850

1 Answer

My truck wont start


ignition switch,,or,,battery dead,,or ,,broken wire at starter

Jan 31, 2010 | 1988 Chevrolet S-10

1 Answer

Car used 2 days ago fine. Went to start today and the remote only opened the driver door. Put key in ignition and hazards went off then made a clicking noise when tried to turn over and the lights on the...


Yes, this sounds like a flat battery. You could try to get a jump start off someone else, so that you know it is definately not the engine. Otherwise, purchase a new battery and you should be fine.

Jul 25, 2009 | 1999 BMW 328 Series

1 Answer

Ford focus 53 plate wont start


may have problem with selonoid on top of starter jamming give it a tap with hammer then try

Nov 22, 2008 | 2003 Ford Focus

1 Answer

I have a 2001 GMC Yukon. It was running fine until two days ago. I went to start it on Saturday and it would only make a clicking noise. I was able to start it with jumper cables. I drove for an hour...


i had the same exact problem with my chevy s-10, but once i replaced the battery it ran fine no problem, u may have fried some circuits and relays while jumping the car, and alot of times that clicking noise is your relay burning out, did your car start doing weird things too? like ejecting cd's, flashing lights really fast and weird noises?

Jul 21, 2008 | 2002 GMC Denali

Not finding what you are looking for?
2000 Mercury Mountaineer Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

fordexpert

Level 3 Expert

5530 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...