Question about 1995 Chevrolet Lumina

1 Answer

Seems oil pump not working - 1995 Chevrolet Lumina

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 7,353 Answers

Thats pretty serious.....what makes you think that? what is the oil pressure at idle, at 2000 rpm, hot, cold. did you ck the oil level? the engine should be knocking unless you turned the engine off right away when the oil light came on, the oil pump is driven by the cam gear and the oil pump drive shaft. you can see the top of the driveshaft on the drivers side of the engine there where a distributor would be.

Posted on Sep 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 93 Nissan Altima and it seems to be getting oil in every place other than in my heads is this due to oil pump or what could cause it


have you done any head work lately ( head gasket blocking oil galley to head)
thee are engines that supply oil to the heads via a hole in a main bearing hole
it has been known for the bearing shell to turn and obstruct that hole
to eliminate the oil pump have a mechanical gauge fitted to the block oil galley and get a reading if it is normal or within specifications then that will rule out the pump

Jul 02, 2015 | Nissan Cars & Trucks

1 Answer

Nissan XTRAIL QR20 OIL PUMP NOT WORKING


New oil pumps will not work until they are primed . Pull the pump and remove the gears cover Fill the space around the gears with Vaseline / grease and replace the cover/pump. When the engine starts to spin the gears will move the Vaseline out into the oil galleys and create a vacuum which will suck up the oil. The Vaseline/ grease will disperse back into the sump with no ill effects. Ensure the oil pick up pipe is securely in place.

Jun 07, 2013 | Cars & Trucks

2 Answers

To oil press down to 0 when engine is running


Hi!!
Check Oil Pressure Switch, make sure is properly connected and working, if all seems OK, take vehicle to a Garage to have Oil Pump tested. I would recommend not to drive the vehicle if Oil Pressure Switch is or seems to be working correctly, damage to the engine and components can occur.
Good Luck!! A HELPFUL - 4 THUMBS - rating for this solution would be greatly appreciated. Thank you for using FixYa.

Jan 12, 2011 | Toyota Sequoia Cars & Trucks

1 Answer

I have an 02 wrangler and the oil preasure goes down when Idling is that an oil pump going bad?


First we would need to know when this occurs. Asuming the oil level is at the full mark!. If the pressure goes up during acceleration and down at idle when engine is fully warmed up, then this is normal. An engine requires 10 psi of oil pressure per 1,000 rpm ( ex. 20 psi at 2,000 rpm, 25 psi at 2,500 rpm, and so on ) . If the gauge is moving back and forth erratically at idle , i would say the gauge is bad. If it drops to 0 while accelerating I would say your oil pump is bad. If from time to time it seems to work and other times it seems not to work, I would say the oil pressure sending unit for the gauge is bad. If the pump failed you would start to here a Knocking noise from the engine in a short period of time. Use the above scenario's to narrow down what it may be.

Oct 16, 2010 | 2002 Jeep Wrangler

1 Answer

Oil pump is going bad in my 1999 chevy lumina


First we would need to know when this occurs. Asuming the oil level is at the full mark!. If the pressure goes up during acceleration and down at idle when engine is fully warmed up, then this is normal. An engine requires 10 psi of oil pressure per 1,000 rpm ( ex. 20 psi at 2,000 rpm, 25 psi at 2,500 rpm, and so on ) . If the gauge is moving back and forth erratically at idle , i would say the gauge is bad. If it drops to 0 while accelerating I would say your oil pump is bad. If from time to time it seems to work and other times it seems not to work, I would say the oil pressure sending unit for the gauge is bad. If the pump failed you would start to here a Knocking noise from the engine in a short period of time. Use the above scenario's to narrow down what it may be.

Jul 02, 2010 | 1999 Chevrolet Lumina

1 Answer

I replace the oil pan gasket and i had to removed


if you drove it for any length of time you would know if it was workin or not cause you would have a blown engine from no oil

Apr 04, 2010 | 1989 Ford Bronco

1 Answer

The oil pressure gauge goes from 0 to all the way up and the needle moves back and forth while driving it checked oil its good now its clicking underneath the car and it felt like the transmission was...


First we would need to know when this occurs. Asuming the oil level is at the full mark!. If the pressure goes up during acceleration and down at idle when engine is fully warmed up, then this is normal. An engine requires 10 psi of oil pressure per 1,000 rpm ( ex. 20 psi at 2,000 rpm, 25 psi at 2,500 rpm, and so on ) . If the gauge is moving back and forth erratically at idle , i would say the gauge is bad. If it drops to 0 while accelerating I would say your oil pump is bad. If from time to time it seems to work and other times it seems not to work, I would say the oil pressure sending unit for the gauge is bad. If the pump failed you would start to here a Knocking noise from the engine in a short period of time. Use the above scenario's to narrow down what it may be.

Mar 27, 2010 | 2005 Nissan Altima

1 Answer

I have a 1997 Chevy Blazer that has oil, but no pressure


There's something you can do to check if the oil pump is still working screw off the oil filter and start it only for a few seconds if oil shoots out the pump is working if it doesn't the pump could be clogged or it lose prime if it's working check the wire going to the oil pressure switch may be broken.

Jan 04, 2010 | 1997 Chevrolet Blazer

1 Answer

OIL PUMP PROBLEMS


check valve in or check oil filter,did you do the timing belt,that runs the oil pump on a 2.0

Mar 19, 2009 | 1996 Plymouth Breeze

1 Answer

2001 VW 1.9L TDi OIl pan and pump


well if you can get a new pan, gasket and oil pump for $150...by all means replace it.

Mar 18, 2009 | 2001 Volkswagen Golf

Not finding what you are looking for?
1995 Chevrolet Lumina Logo

Related Topics:

74 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

77169 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...