Question about 2000 Suzuki Esteem

1 Answer

1999 suzuki esteem hard to start, just cranks and cranks. Runs perfect once started. Has new spark plugs oxygen sensor and cleaned injectors. Anybody know what problem is?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 299 Answers

Check to make sure the fuel pump,injectors and fuel pressure regulator don't have any internal leaks check the fuel pressure immediatlly after it is shut off and two hours later there should be at most a very slight difference

Posted on Sep 25, 2009

Testimonial: "Great help. swift response. Thank You"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hard start runs rough floods bad


Well--I usually would say do some testing

BUT- on a 23 year old vehicle--I would mail away
the injectors & have then tested & Ultrasonically
Cleaned

Then install new spark plugs

Next check fuel pressure

New oxygen sensors-again- I assume nothing has
or is every been done to it

Clean the MAF Sensor & check for Vacuum leaks

Jul 27, 2014 | 1991 Ford Explorer

1 Answer

1998 Suzuki Esteem ran out of gas. Still won't start after putting in gas. Is there a way to prime it.


putting gas where?
gas tank
or doing the Test fuel procedures?
is this a barn find/ field found car, or it ran perfect last week, and DD for months. (daily driver?) all this maters and is unstated.
1.6L or 1.8L engine, G16 or J18 suzuki enignes? major different they are.
with old engines, we do this and win every time.

all FUSES good, (EFI and spark fuses up to 3 or more)

1: compression test, sparks out , wide open throttle. warm to hot engine.
180psi on all,, good, if like 90, the timing belt slipped. if J18. we have
3 folks now on our forum that managed to slip a chain (they ingored huge noises from engine,,,, amazing)
2: spark got good on all 4 cylinders. and timed right not guessed at
using a real tool called a timing light for 20 bucks.
3: with fuel pump relay pulled i test engine on test fuel.
runs for 3 seconds, each spray and SOUNDS good.
ok it does that.. (this avoids flooding issues)
4: i put back the fuel pump relay.
and it dont start. i check for injection,
i find all injectors, dead.
the ECU is cutting injection,
i connect scan tool and see the CKP DTC errors , the CKP is dead
or CMP on G16. dead. the ECU reports them cranking only, on a dead engine.
the ECU will cut fuel if it seen spark dead.
the ECU will cut fuel if the TPS sensors signals wide open throttle cranking
i checked all that and its good.
i find fuel pressure a 0 , cranking, (one more cheap tool)
i find 12vdc good to pump cranking (a 10 buck meter at walfart)
the pump is bad. no the wires are corroded. at the pump line....
super common on old cars.

this is 1 example path of 100s.

http://www.youtube.com/watch?v=064Ilsz8Fzg&NR=1&feature=fvwp





Jun 26, 2014 | 1998 Suzuki Esteem

1 Answer

Suzuki Aerio 2004, will crank over floods out tho. Changed Plugs and Boots. New baterry too. Can smell gas @ Tail pipe. Wants to fire-but just won't catch. Where do I start looking for the answers.?


what engine? 2.3 or 2.5L?
all cylinders flooding??? spark tips on ALL dripping in gas?
check spark at all spark plugs ( ALL not just ONE)
if spark is good.
this engine is chain cam, so it makes huge noise before death.
did it?, nah
ok, so connect any $9 scan tool, and scan it. (barrow /rent.?)

you crank it for 5 seconds, not less.
and as you crank the scan tool RPM shows 250 to300 rpm and fails to start, the RPM on the tool shows you that the crank sensor is working
now release the key and do not turn off
look for DTC errors. got P0340,355? or any other DTC
that decodes to bad CMP or CKP/
yes, BINGO, the scan tool told you why spark is dead, or way off
timing,

the PCM will report Cmp or CKP errors even 1 in 6 pulses.
the PCM runs monitors against these 2 full time. and will see it fail.
and report, it, let it tell why spark is bad.
say spark is good. and still floods.
1: engine compresssion over 150psi? W.O.T?
2: flooding , i pull the fuel pump relay and crank now.
starts and runs for 3 -5 seconds, yes, that is the flood clearing
so i then try test fuel, runs perfect now (no fuel pump) ???
runs for 3 second, each test fuel usage. well good motor, good spark.
what more do you want? sure to run
so you have either insane high fuel pressure. or injectors leaking
can and does happen.
the tests are all in the FSM under injector and pump testing.
i check fuel pressure first. as its a mandatory thing.....
to factory spec. for unsaid engine.
then i do a injector leak down and balance check.
ask if you get this far.....????


Jan 24, 2014 | 2004 Suzuki Aerio

1 Answer

My suzuki grand has a hard starting in the morning or when the car sits for sometime


CHECK COOLANT TEMP SENSOR I.E.IF THE SENSOR IS READING 200 DEG. IN THE MORNING AND ITS ONLY 70 DEG
OUT SIDE IT WHOLD BE STARTING TO LEAN

Jul 13, 2012 | 1999 Suzuki Grand Vitara

1 Answer

I have an esteem 1999 2 injectors aren't getting electricity from the ecu spark plugs are all hot w 3-4 inj. working properly but why would this happen


Don't know. Either a malfunction internally in the ecu, or bad wires from ecu to injectors. You could pull off the ecu connector and check for continuity on the wires from ecu to the two injectors. If the power.wires are not broken and show low resistance, check both ground wires from the two injectors to ecu for continuity. If the wires are good, it must be the ecu.

May 30, 2012 | 1999 Suzuki Esteem

2 Answers

1999 GMC Suburban K1500 5.7L. When it is first cranked, doesn't matter if it is first crank of the day or the tenth, it will idle ok but when it is put in gear it studders and acts like it isn't...


Thanks for choosing FixYa Chris and welcome. Since you already have tested fuel pressure and changed the MAF, I would suggest changing your oxygen sensors. This is why. If the fuel pressure is correct, then there shouldn't be a bad fuel injector or clogged filter. The MAF can cause this issue, but since it is new, you know it isn't. Since you have the hard start and the problem goes away after the vehicle warms up a little, it would appear that one of the oxygen sensors or all are defective. Isn't code 0171 for the O2 sensor? I believe so but I am not 100% sure.

Jul 17, 2011 | 1999 GMC Suburban

1 Answer

Hard to start runs ok after you get it started


Could be fuel pump relay, Plugged fuel filter, Bad spark plugs.
You can also check your crank sensor if you have coil packs and igniton module to make sure it is sending a signal every time the crank rotates thus providing spark to ignition module, plugs wires, and to plugs.
You can check the relay itself with an ohmmeter, place tester in ohm setting, place one probe on each side of relay

Dec 01, 2009 | 1989 Chrysler LeBaron

3 Answers

1998 suzuki esteem 1.6 will not start HELP!


Having good fuel pressure is a plus (yours seems a bit high but I don't have specs) What you need to find out is if the injectors are opening and putting the fuel into the engine so it can work. Are the plugs wet with fuel or dry? Does it fire up if you spray carb cleaner into the throttle body while cranking?

Aug 30, 2009 | 1998 Suzuki Esteem

1 Answer

After car warms up and stops wants to cut off


Sounds like you need a fuel pump. If its the original with114,000 miles then replace it.

May 21, 2009 | 1999 Suzuki Esteem

3 Answers

SUZUKI baleno starting up but losing its power


Check crank angle sensor. Mine run until warm, pinlks badly/stalls, engine check light then comes on a car runs ok. Ran diagnostic and came back with a faulty crank angle sensor

Nov 04, 2008 | 2001 Suzuki Esteem

Not finding what you are looking for?
2000 Suzuki Esteem Logo

Related Topics:

506 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76070 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...