Question about 2003 Mitsubishi Lancer

1 Answer

Car shut off @ 65 mph and wont start again.

I was driving down the interstate and my car shut off at 65 miles an hour. i lost power steering and it sounded like i had broken a belt or threw a rod. it took all i had to yank it onto the side. now it wont start. its got power but when you crank it it just doesnt get that kick it needs to turn over.. help! where is the starter located?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 347 Answers

You may have a broken alternator belt or timing belt.

Posted on Sep 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

While driving on the interstate, my 2011 Mustang GT suffered a complete electrical shut down. The car died and nothing electrical will work. Twelve hours later i still do not have any electrical powe


ck the back of your alternator , ck the wires , also the same for the starter sounds like a wire broke of or shorted out , look good you will find it or your alterantor went bad and will kill the battery for sure , ck that too,

Dec 15, 2014 | 2011 Ford Mustang GT

1 Answer

2008 GMC Envoy


this sounds like is a lost joint in the engine or a broken gear box

Jul 08, 2008 | 2008 GMC Envoy

1 Answer

Loss of engine power/transmission 2001 chevy tahoe over 65 mph


Sound's as though a previous owner installed a speed governor so that the engine would not exceed the nationwide 55-65 mph speed limit average. This most likely was a company owned vehicle or owned by someone concerned about speeding ticket's or excessive speed by a teenage driver. It can be uninstalled by an experienced mechanic. Unless this poses a problem while driving on an interstate, you may wish to leave it as is.

Aug 03, 2014 | 2001 Chevrolet Tahoe

2 Answers

Steering gone and overhaeating


It's leaking out of your water pump.It is leaking while you are driving,when you stop,it's all gone,on the highway.

Aug 31, 2017 | 1999 Volkswagen Cabrio

1 Answer

Vibrates terribly over 65 mph


sounds like you have a wheel alignment problem. Not enough castor set. Have the front end checked out for loose worn bits. If you have a steering shocky in the system it is probably shot and not doing the job of stabilising the steering. Remember if the springs are a bit flat IE the front end is a bit low then the whole steering geometery alters and negative castor results as what you have described

Jan 10, 2013 | 2001 Jeep Grand Cherokee

1 Answer

Driving down interstate at 70 mph car suddenly


i would start in fuse and relay area with voltmeter.

Dec 05, 2009 | 1994 Nissan Altima

1 Answer

1995 k2500 Chevy truck engine runs rough some of the time?


I had a similar problem @105k. I had changed the fuel filter but it was still sending all kinds of codes that were related to 2 problems. Long story short, the main problem was a bad trigger assembly in the distributor (rough running) and the other was a loose engine to body ground (engine code issue). Good luck, this worked for me, now 171k.

Nov 15, 2009 | 1995 Chevrolet K2500

3 Answers

Car shaking and vibrating at 55 mph. and does it again at 65-70.


Hi:
Since your BMW 540 series is a rear wheel drive car, a common cause of that sort of vibration is often the U joints on your drive shaft. The vibration often only shows up and certain speeds.

It isn't a particularly expensive repair, but is something to have checked out!

Nov 03, 2009 | BMW 5 Series Cars & Trucks

Not finding what you are looking for?
2003 Mitsubishi Lancer Logo

189 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8531 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...