Question about 2004 Ford Escape

1 Answer

I did an oil change twice on my car since i owned it. after both times the motor ran rough and now it starts to shake when i reach about 65 mph. what is my problem

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 299 Answers

Usually a rough running engine has nothing to do with an oil change you way have an oil leak onto the spark plugs or you may have a defective pcv system

Posted on Sep 24, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Engine check light showed up when I drove at 65 mph


I would recommend having the computer checked for trouble codes next. The codes will help point a mechanic in the right direction for what to test.

Dec 11, 2012 | Cars & Trucks

1 Answer

Rough idleing in2000 deville


Need a professional mechanic to take a ride with you
driving & check all data,especially short term fuel trim.

The O2 Sesnors have less than 100,000 miles?

Do a cylinder leak down test,you have lots of miles
on the motor,so stay with basics & be sure you have
anything left in the motor mechanically

Don't know the car so what controls the idle,& is there an AIC
Valve to clean

Nov 20, 2012 | 2000 Cadillac DeVille

1 Answer

2001 jeep grand cherokee runs rough while doing 50 mph and feels like the motor is shaking. It runs rough sometimes. The problem is not constant. The wheel will feel like a wheel weight has fallen off,...


As something to start with, I would check your injectors, do an injector cleaner/seafoam treatment. I would also drain the oil, and check with a magnet to make sure there are no metal shavings running around, and check to see if one of the cylinders has lost compression/the spark plug isn't working.

Jun 05, 2011 | 2001 Jeep Grand Cherokee

4 Answers

E ng lite came on pulled to stop light engine ran rough and was shaking ck oil was low filled oil ran better this am wife went to take truck to work got to the end of block engine ran rough brought back...


I don't think the rough running had much to do with oil level, since it started running rough a 2nd time. Check the fuel filter and ignition timing.

Sep 20, 2010 | 2002 Ford Ranger Regular Cab

1 Answer

1995 k2500 Chevy truck engine runs rough some of the time?


I had a similar problem @105k. I had changed the fuel filter but it was still sending all kinds of codes that were related to 2 problems. Long story short, the main problem was a bad trigger assembly in the distributor (rough running) and the other was a loose engine to body ground (engine code issue). Good luck, this worked for me, now 171k.

Nov 15, 2009 | 1995 Chevrolet K2500

1 Answer

Engine light came on , it runs very rough,shakes, lost pwr


It sounds like an ignition problem. Make sure your battery is good and connections are clean. I would start by replacing the plug wires and spark plugs. This is a good tune up procedure anyway and will increase your mileage some. Clean or change the air filter. The obvious thing is to make sure the oil is new and filled to the correct level, not overfilled. Your engine will love you. I hope this helps.

Jun 17, 2009 | 1997 BMW 318

2 Answers

I have a '94 accord LX 5-speed with 111k miles. When I drive above around 70ish mph, the car starts to run a little rough, it begins to shake a little. There is no CEL light on and the oil was just...


Seem like you need to have at-least the two front tires high speed balanced. This shaking at high speed is most likely due to the tire being out of balanced. Good luck and thanks for using FIX YA

May 14, 2009 | 1994 Honda Accord

1 Answer

When i start car it sputters and shakes until 45 mph.


spark plugs wires needs complete tune up also synthetic oil change not designed to run on regular oil then check bearings

Dec 20, 2008 | 1992 Lexus Es 300

Not finding what you are looking for?
2004 Ford Escape Logo

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...