Question about 2003 GMC Yukon Denali

1 Answer

Service ride control 2003 GMC Yukon Denali AWD 200M+ miles

"service ride control" appears in display constantly.
4 times when my husband or son were driving my GMC: "reduced engine power"displayed and speed decelerated rapidly. If you turn engine off, wait 2-3 minutes and restart engine runs normally.
there has al;ways been a noise @ rear end of the Denali immediately after engine starts. Sounded like adjusting height (or something else?). Buzzing sort of sound. Might this sound have ceased when "service ride control" alert appeared? Do not ever hear it anymore.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Most likely it is the ride adjustment height sensor acting up.
The vehicle is going into LIMP HOME MODE. Only lower gears are available - to protect the engine from further damage.

Take the vehicle to your local parts store, and have the OBD codes read for free. This will give you insight as to what the computer is seeing that is making it want to protect itself.

The Ride Adjustment isn't making the Limp Home Mode activate - so it is likely you have multiple issues. Limp Home is usually reserved for transmission issues.

If you get the On Board Diagnostics read - re-post with the findings and I can help you with repairs or verify a mechanic's suggestion of repairs.

Thanks for using FixYA!!

Posted on Sep 23, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Service stability message in my gmc yukon denali 2004


my 2003 is now saying this .. my mechanic said the struts are going out maybe this is your cars problem too ? just a thought but i Would go in for a free service check on that ride before something major happens on the road while your driving it

Dec 29, 2010 | 2003 GMC Yukon Denali

1 Answer

DISABLING SERVICE RIDE CONTROL via REPROGRAMMED BCM


bottom of sterring colum under under trim panel

Jul 19, 2009 | 2005 GMC Yukon Xl Denali

1 Answer

2003 gmc yukon denali xl starts but gas not flowing engine could it be a loose gas cap or fuel pump. Fuel filter changed. Also what does service ride control mean Singlemom03


if your engine starts up and dies right away the you probably have a fuel pump problem and the service ride control mean that your air ride compressor has gone bad just turn your key to the on position and wait about 30 seconds you will here buzzing from the left rear wheel area if the compressor is working

Jul 18, 2009 | 2006 GMC Yukon

1 Answer

2003 GMC Yukon XL Denali Service Ride control info


leaking suspension air bags is the most common cause, but the system can be tested for trouble codes, I suggest u do so, only the dealer can do this, but guessing about what the problem is can get very expensive very fast.

May 13, 2009 | 2003 GMC Yukon

3 Answers

2005 gmc yukon xl denali service ride control


it has to do with your air ride suspension best bet is take it to the dealer there is probably a problem with a level sensor. hope this helps you

Mar 16, 2009 | 2005 GMC Yukon Xl Denali

2 Answers

I start my 2003 denali, a message of service ride control appears


my service ride control was on took to dealer said exhaust valve was bad new compressor was installed prts n lbr 875.00

Mar 14, 2009 | 2003 GMC Yukon Denali

Not finding what you are looking for?
2003 GMC Yukon Denali Logo

Related Topics:

229 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...