Question about 2000 Oldsmobile Alero

1 Answer

2000 olds alero shuts off while driving

My 2000 olds alero starts up fine but after i drive for an indeterminate amount of time it shuts off. I can no longer accelerate and just have to drift to the side of the road. We have replaced the crank shaft position sensor and had the ignition module tested but we cant seem to fix the problem. previous owner says he just replaced the fuel pump. please help.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 811 Answers

Open gas cap turn key to on position listen for whirling sound ,if not, check fuel pump relay, check for fuel pressure 

Posted on Sep 12, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My car was running fine and out of nowhere it just shut off and it wont start back


The same thing happened to my 03 olds Alero, i pluged my scan tool in and found out that my fuel pump was bad, I changed the fuel pump, fuel filter, and also checked the fuel injectors and blew out the fuel lines, now it's running great.

Feb 27, 2015 | 2003 Oldsmobile Alero

1 Answer

Cant find the crank position sensor in 2000 alero


Check that the cam shaft is turning as it may have broken a timing belt. Run fault codes to check for cam/crank position sensor problems.

Jan 06, 2014 | 1999 Oldsmobile Alero

1 Answer

2000 alero won't start. turns over and fires but wont start


make sure your cap and rotor timing is correct double check spark plug routes (mistakes happen). maybe your timing is off in general.

Jan 16, 2010 | 2000 Oldsmobile Alero

1 Answer

Quits while driving replaced many suspected parts


try this, the next time it quits leave the key in on position and get a broom stick and go to the passenger side of the car. About straight in at the back of the door ,reach under with the broom stick and tap the plastic gas tank a few times, have someone try to start it or go start it yourself. Mine did this even after the garage checked it out and cleaned the tank. Come to find out dirt settles around the fuel pump and clogs it. They just blame the pump but in my case the pump was fine. I was told Alero used a very small fine mesh in the sock that goes in the fuel pump and they clog up. But most of the dirt was around the plastic guard around the fuel pump. See if this works and let us know. Good luck

Apr 04, 2009 | 2000 Oldsmobile Alero

1 Answer

2004 Olds Alero with constant high RPM


Try cleaning the throttle body. Possible idle air control valve problem.

Mar 15, 2009 | 2004 Oldsmobile Alero

1 Answer

2002 old alero 3.4L itermittent no start, star and stall


My daughter has the same problem and has been in contact with GM. The problem is the system, not the battery or fuel pump etc. GM has no direct fix or parts to repair. The battery disconnect/reconnect works best, its what a dealer will do and they reset the computer even though they find no error. Alero is also is prone to bad motor mounts effecting grounding which can cause the same problem. GM replacement mounts are the same as the problem mounts. Battery reset works here too. Since Olds is gone they won't invest, especially now. carry the battery wrench, drive it till you can't stand it any more and then trade in. Look at the net, its full of the same problem in multiple years of that Alero version. Shame its a nice car.

Dec 30, 2008 | 2002 Oldsmobile Alero

1 Answer

2000 Alero hard to start


I had this problem with my 1999 alero i took it apart and investigated it myself because i have been a mechanic for 25 years now but i had to replace the starter relay the whole ignition system and believe it or not new valves. After I replaced all of those my alero drove better then eer and the lights never went back on or any of the other lights....

Dec 19, 2008 | 2000 Oldsmobile Alero

1 Answer

2000 olds Alero shutting off while driving


Check the 02 sensor and the ignition switc.

Oct 10, 2008 | 2000 Oldsmobile Alero

Not finding what you are looking for?
2000 Oldsmobile Alero Logo

706 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...