Question about 1997 Chevrolet K1500

2 Answers

Vaccum hose diagram for 97 chevy tahoe 5.7 liter

Engine idles rough but runs good at normal operating conditions. Replaced egr valve and found a vaccun line connector on sensor(?) on passenger side, top, front of engine w/o a hose connected to it. Sensor is directly under the air intake housing on top of the valve cover. Also found bad hose on vaccum sensor(?) on firewall,passenger side, under a/c canister.

Posted by on

  • Anonymous Mar 22, 2014

    Hearing a humming sound in my car from under hood but can't really pin point where the sound coming from but it's on the passenger side my friend took a look and the vaccum up top the hose is sick in at the top is it suppose to be lice that

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

I have the diagram you need. If you send me your email I will scan it off and send it to you. outdoorsman592003@gmail.com

Posted on Sep 12, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 242 Answers

It's great that you are finding all the bad hoses- it will run so much better after you have reconected and replaced all of the bad/rotten ones that you find. You should have a vacum diagram on the radiator support or on the underside of the hood. Once you have located a few of the key componets, you should be able to follow it. If for some reason that your diagram is missing, Haynes manuals now also include vac diagrams.

Posted on Sep 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

97 ford escort p401 code


You may have carbon plugging the passages on the intake side of the valve. Remove the valve and start the engine. It should die or run very rough. if it idles normal then you have blockage that needs to be cleaned out.

Dec 05, 2013 | Ford Cars & Trucks

2 Answers

Rough idle problem


could be a vacuum leak at a hose or gasket. with the engine running spray a little carb spray at the intake manifold area. if the idle picks up you are close to the vacuum leak. dont spray on the exhaust manifold area, be careful

Oct 24, 2013 | Cars & Trucks

1 Answer

1995 chevy tahoe 4wd. 5.7 liter when cooled down, starting is normal . Right after, engine almost stalls but Idle air control kicks in and keeps it running. eventually it is idling but rouph. On...


If your vehicle has one, and I think it does, check your EGR system. If the egr valve is full of carbon, it can be partially open, creating a vacuum leak. If the egr valve solenoid is bad, it could be opening the valve at the wrong time, also creating a vacuum leak. Unplug the egr vacuum hose, plug the open end of the hose and start it and see what it does. A picture of the egr is below.
3_11_2017_5_29_14_am.jpg

Mar 11, 2017 | 1995 Chevrolet Tahoe

1 Answer

Dodge 3.3 engine began running rough. Poor idle. Stumble's on accelloration and backfires. New O2 sensor, new coil, plugs and wires recent. Dissimbles upper engine checked injectors, egr and found vaccum...


had a similar hard-running problem with a 96 ES 3.8 V6; pulled the front valve cover and rocker-arm tube over #5 had split and no longer controlled the i/o valves. had to replace and re-machine #5 valves in the head.

Aug 29, 2010 | 1996 Dodge Grand Caravan

1 Answer

I have a 1996 F150 4x4 with a 5 liter/302 engine, manual tramsmission. When I push the clutch in to shift the engine races and the tach goes up then after a few minutes it will idle down. I have replaced...


Check the PCV valve and the PCV hose where the elbow is near the TB. It may be stuck open and the hose may have a crack, Squeeze it while engine is running. Also are you sure its not brake related. The check valve on the booster can fail. Does the RPM change when you apply just the brake ??
Also spray some brake cleaner around the base of the TB looking for a RPM increase. Spray around any vacuum source.

Apr 14, 2010 | 1996 Ford F150 Regular Cab

2 Answers

98 Chevy Tahoe 5.7 liter engine cuts out and misses. It happens when the engine is up to operating temperature and under load. At idle - after engine is warm - it runs rough sometimes, but when it is put...


Have you checked for vaccume leaks?
You've got lots of parts in there, Has the problem been the reason you have replaced all of those, or did it come up while doing some of the repairs?

Dec 18, 2009 | 1998 Chevrolet Tahoe

2 Answers

1997 Ford Contour with a rough idle while stopped


This is a common complaint on these cars. I own a 96 myself.
Assuming that you engine is fine and runs smoothly under normal operation, and just is rough "feeling" at idle while stopped; then I would suggest changing the motor mounts...the mounts may not be broken, but the rubber isolators get worn and soft, and transffer normal engine vibration into the chasis of the vehicle. Mine was doing the same after changing the mounts good as new again.
Please note...don't use cheap mounts, by the better grade/quality mounts.

Aug 27, 2009 | 1995 Ford Contour

1 Answer

97 Eclipse over heating, rough idle, stalls out


Do a cooling system pressure check for a blown head gasket.

Jul 07, 2009 | 2000 Mitsubishi Eclipse

1 Answer

Will not start


Check if fuel or spark problem,..all engines need both to run...use starting fluid in air intake ,..if it runs very shortly-fuel pmp?,,ck for spark at spark plug,work your way back..also ck timing belt-intact? Kev-MN

Nov 30, 2008 | 2000 Ford Ranger SuperCab

Not finding what you are looking for?
1997 Chevrolet K1500 Logo

2,731 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8265 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...