Question about 2005 Ford Expedition

1 Answer

2005 ford expedition a/c problems

A/c will not come on at all gives temperature sensor codes

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,111 Answers

1st look up the codes and it would sound as if the compressor oil is low or merely needs a recharge

Posted on Sep 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Coolant temperature sensor location on 97 ford expedition


I believe they are located in the intake manifold somewhere. Make sure the one that tells the computer the coolant temp is ACTUALLY giving out the correct temperature. I had a bad one one time in a 1993 Ford F-150, 5.8L....... no check engine light came on but hard to start. The bad sensor was telling the computer it was 32 degrees F when it was almost 80 degrees outside.!!
Garbage in=Garbage out.

Here is a video link from Youtube. There are 2 sensors, 1 for the guage and the other tells the on-board computer how hot/cold the coolant is. The one for the guage has 1-wire and the other one has 2 wires.
Hope this helps, ask more if you need to. What kind of problem are you having? No heat inside? Guage needle not getting into the normal area?


1997 Ford Expedition 5 4L V8 Triton Engine Coolant Temperature ECT Sensor...

Oct 20, 2015 | Ford Cars & Trucks

1 Answer

I HAVE A 2005 FORD EXPEDITION THE PROBLEM IS A CODE P0420


http://www.ford-trucks.com/forums/1011390-06-expedition-xlt-p0420-code.html

Mar 17, 2015 | 2005 Ford Expedition XLT

1 Answer

Where is the temperature control sensor on a 2005 ford expedition


If you mean for the cabin temp of an atc system, it should be in the dash area near the centre. There should be a small square with slots in it .

Feb 20, 2015 | 2005 Ford Expedition

1 Answer

P1289 code ford expedition


P1289-- Cylinder Head Temperature (CHT)
Sensor Circuit High Input

If sensor voltage is above 4.6V, key on eng off
replace sensor,if not check for ground

Jun 21, 2012 | 2005 Ford Expedition

1 Answer

P0125 in a 2002 ford expedition


p0125 is closed loop fuel control insufficient coolant temperature.
A code P0125 may mean that one or more of the following has happened:
  • Insufficient warm up time
  • Low engine coolant level
  • Leaking or stuck open thermostat
  • Faulty coolant temperature sensor, just reset it and see if the code comes back on. good-day !

Oct 20, 2011 | 2002 Ford Expedition

1 Answer

What is wrong when a 1998 ford expedition cranks but won't stay running unless I give it gas.?.


There should be a trouble code stored in the computer go to Auto Zone they will read the codes for free, the code retreived will help you narrow down the problem instead of guessing, this problem could be a number of things from a misfire, bad MAF sensor to a bad throttle position sensor.

Dec 08, 2009 | 1998 Ford Expedition

1 Answer

Check electronic throttle control


We have been experiencing same faults on a 2005 Expedition,with engine stopping and the message "Check electronic throttle". Ifirst went to AutoZone and they read the codes. They suggested replacing thethrottle sensor, which we did, but car stopped again. We had to replace thebattery in a month and this is the fix. The battery was almost 6 years old andwhen you first start your engine, it sucks too much load and gives these faultsto the computer. It never stopped since then (3 mo already). Sometimes we useto get the message 3 times a day.

Sep 22, 2009 | 2005 Ford Expedition

Not finding what you are looking for?
2005 Ford Expedition Logo

Related Topics:

224 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...