Question about 1994 Cadillac DeVille

1 Answer

The transaxel was rebuilt - now the speedometer jumps around at about 60 mph in overdirve and the cruise control cuts in and out. When in drive the speedometer jumps round at about 40-45 mph. The transaxel wines between shifts, after shifting into drive or overdrive it quiets down. at 40 to 45 mph the car jerks around - seems to be shifting in and out of overdrive?

Posted by on

  • david_kvalst Sep 11, 2009

    Thanks ginko,

    I will return it to the garage with your remarks and see if they correct the problem and let you know. I suspected the same but wanted some concurance before I took it back to them. Dave

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Cadillac Master
  • 19,396 Answers

After replacing the transaxle, the Transaxle Input Speed Sensor is damaged or it had been mounted incorrectly. The problem can also be a Vacuum problem.

Testing vacuum it is easy. this is tested using a pressure gauge in vacuum lines, and pulling OBD codes.

Service codes may also confirm that there is a problem with speed sensor.

Being the speed gauge affected , the problem is almost for sure speed sensor.

On a Deville Transaxle Input Speed Sensor is located inside the on the transaxle.

The sensor can be accessed removing the transmission side cover.
Fixing the sensor may be quite a complicate job.
If you have replaced transaxle at a garage have it fixed by the mechanic, as the original repair had not been done the way it should be.

Here all doagrams for your car.

Posted on Sep 11, 2009

  • Ginko
    Ginko Sep 11, 2009

    Hi David,

    I think going back to the mechanic will be the best choice. Replacing the transaxle is not a simple repair (and not cheap), a lot of work is involved, and if you get this kind of problem after replacement, then something must have gone wrong. In your case it is almost surely the speed sensor.


    Thanks for keeping us updated.

    G.


×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedmoter jumps to 20 when i put truck into reverse or drive


SOUNDS LIKE A BAD SPEEDOMETER if you can use an OBDII while driving and look for DTC output from speed sensor. possible loose connection can cause this as well

Nov 06, 2012 | Ford Cars & Trucks

2 Answers

Speedometer is working but reading way off


It appears that you need to have the speedometer calibrated. Unfortunately, this is very challenging. You'll need to take it to a mechanic. Dependent on where you take your Envoy it can cost around $75+

Jan 10, 2012 | 2003 GMC Envoy

1 Answer

Driving down freeway at 60 mph the speedometer just quit then after I left freeway the car would not shift out of 2nd gear.


you probably have a bad VSS. while driving the car see if your cruise control will engage. if it doesn't , replace the VSS. (vehicle speed sensor) It will also cause your car not to shift correctly if it is not working.

Mar 13, 2010 | 1999 Chrysler 300M

1 Answer

'99 Beetle cruise control surge and speedometer has slight flutter.Occasionally speedometer drops to zero mph and cruise will then stop working. The "surge" is so bad that you can not drive with cruise on....


I would take a blind guess and sat the speedo sensor has an issue. 99' beetle should have an 01M auto, and the speed sensor is also the dipstick for the final differental drive. search around this area of the trans for the cable and snoop around. loose at the trans ? bad connection somewhere??

Dec 09, 2009 | 1998 Volkswagen Beetle

1 Answer

I'm having a problem with my 1990 Volvo 740's speedometer. It fluctuates erratically and the odometer does not work either.


Check the connection at the speed o sensor. It's in the differential cover, about 3" above the filler plug. Be sure it's mechanically secure, and check the contacts (both sensor and connector) for signs of corrosion or oxidation. As much as possible, examine the harness for any signs of a break or tear, or for signs the wire might have been cut. If it's not wiring, then it's either the sensor or the speedometer head (which is electronic). Possibly, the power supplied to the speedo head where it's mounted in the dash cluster is intermittent. The speedometer in my 745 with 160K has been jumping around a little on the highway. The cruise control would try to follow the erratic speedometer, then disengage. I suspected a broken wire at the sending unit. What I found was a burnt wire at the sending unit. The wire had grounded out on Volvo's safety wire. I suspect that the safety wire slowly eat through the insulation on the wiring, causing it to ground out. The plug was melted and an inch or so of insulation on the green stripe wire. Make sure the safety wire is not cutting into the two wires on the sending unit at the back of your rear end. [Response: Scott] Check the instrument cluster grounds under the dash and in the right footwell. In 88 there were some 700 series cars that would register up to 60 mph while sitting still and the grounding problem was the cause.

Jun 29, 2009 | 1990 Volvo 740

1 Answer

Speedometer problems


It may be that the speedo cable has come loose at 1 end and will need to be tightened back up. Sorry but not sure where ends are attached on your car.

Mar 28, 2017 | 2004 Buick LeSabre

1 Answer

Speedometer reading fluctuates


IMHO, I think that the broken cable is what is causing the problems. It "confuses" the programing of the CPU or computer.

Dec 17, 2008 | 2003 Chevrolet Silverado 1500

2 Answers

94 1500 speedometer


bad speed senor on trans

Oct 09, 2008 | 1994 Chevrolet C/K 3500

Not finding what you are looking for?
1994 Cadillac DeVille Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...