Question about 1985 Pontiac Firebird

2 Answers

86 transam runs perfect cold then like a dog if you start it hot

Always starts easy hot or cold, will run perfect from cold start but if you turn it off when up to temp it will be really rough about 80% or the time, like running on 7 cylinders. funny thing is on some days it wont play up at all. replaced plugs (didnt know the proper gap so left them as supplied) and leads. makes me not want to drive my toy

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Pontiac Master
  • 22,219 Answers

Check for cracked dizzy cap ??and the carbon button in the middle

Posted on Sep 11, 2009

Testimonial: "thanks mate, ill give it a try before i go to the trouble of changing the injectors"

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,129 Answers

You may need new spark plug wires or a new ignition module when the wires or ignition module heat up they can leak votage I would replace the plug wire first if they are old also make sure the plug wires are not touching any metal surfaces or each other I have seen plug wires cross fire when they rub against each other.

Posted on Sep 11, 2009

Testimonial: "done that, i went with straight boots and ran them over the heads so they stay away from the pipes and they cant get burnt. "

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What could be the problem? 86 sedan deville


Have you replaced fuel filter ? Does this problem happen when engine cold or also hot

Dec 14, 2016 | Cars & Trucks

1 Answer

Kia carens 2008 crdi not starting when hot, turning over easy, new battery fitted, any ideas greatly appreciated, starts fine when cold.


run the fault codes
not starting hot indicates an electronic component problem when hot
could be faulty cam/ crank position sensors, immobilizer or ECM

Jun 16, 2016 | Kia Cars & Trucks

1 Answer

1990 jeep wrangler runs rih won't stay running replaced map sensor and temp sensor


which engine,? the have up to 3 choices.
rih?
what are the full symptoms,
did you do the full listed 60k mile tune up on car?
sparkplugs,wire, cap rotor/filters? no engine runs right with bad spark
unless it's a diesel.
starts good
runs good or bad hot or cold engine
idle at 800 RPM hot?
stalls> when hot and cold engine
lost of power
bogging
misfire,
learchs>

only stalls , but runs perfect even up hills, at wide open throttle.
fresh gas, or 1 year old?fuel.
can your fast right foot , save the stall, and easily?

ok stalls 101.
1; lost 12vdc to EFI system.
2: lost engine compression.
3: lost spark.
4: lost fueling or floods
there is a simple test for each.
do you want more guesses, or how to do tests.
can do both, but my guessing fails 99 /100 times.

tune it up
do the right foot test. those are always first. on stalls.
always.







Feb 05, 2014 | Jeep Wrangler Cars & Trucks

1 Answer

I have a carbureted 86 22r pickup. It runs perfect when cold. As soon as the choke pulls off the idle is rough. I have already ruled out the fuel shut off solenoid. It is clean and operates perfectly....


It could be that you have to adjust the idle mixture screw a little . It may be set too lean or too rich which gives what you describe When the engine is at operating temperature turn the screw in or out a bit until the motor runs better. Adjust then until it starts to run rough then screw it the other way until it starts to run rough again. Correct mixture will be in the middle of those points.

Jul 21, 2013 | Cars & Trucks

1 Answer

86 f250 straight 6 Running lights always stay on


You have a Hot wire someplace, Start disconnecting Fuses and locate the system. this will get you down to a smaller search area.

Good Luck

Apr 12, 2013 | Ford F-250 Cars & Trucks

1 Answer

Problem changing gears when hot. ok when cold!


It will be best to get someone to check the hydraulics of the clutch. That is a common issue.
Get a workshop to drain the gearbox oil and flush the system. A tell tale may come from the drained oil if the tranny is near end of life.

Oct 03, 2017 | Rover 400 Cars & Trucks

1 Answer

98 Escort Hard starting when hot


sounds like a dodgy mis reading of a sensor caused by electrical resistance which is turning choke on and flooding engine.know the fault but without car in front of me its difficult to diagnose,could be auto choke sensor which is on right hand side of cylinder head ,but not sure.best is probally dealer have you tried spark plug gaps ??25th although this would cause problems with cold starting not hot starting but its worth a look

Nov 27, 2008 | 1998 Ford Escort

1 Answer

86' si starting problem


the fuel pump may be wearing out if its getting hot. i would suggest changing it out

Aug 22, 2008 | 1986 Honda Civic

1 Answer

Audi 80e 1991 hard starting when cold


I've owned the same car. Check that the fuel relay 'primes' the system before you start the car. When you turn the key to the on position (all you dash lights, ready to start) you should hear the fuel pump run for a second or two. If it doesn't run you can replace the relay for about $30. If the relay is not the problem, it may be a check valve within the fuel line to the engine. This valve keeps fuel from draining back to the tank when the car is sitting. That way, there is fuel close to the motor when it's time to start. The temp senor was not a bad shot, they were thinking it was bad sensor not telling the cold start injector to run. Obviously not the case. However, the injector itself may be faulty in some way. As long as the car always starts, it's one of these problems, assuming the ignition system and engine mechanicals are in running order.  good luck. JK

Jul 05, 2008 | 1991 Audi 80

Not finding what you are looking for?
Cars & Trucks Logo

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...