Question about Chevrolet Nova

1 Answer

Car starts cold but not hot

I have a 1970 Nova that I replaced the 307 with a 350 5.7L. The 350 came with a TBI off of a 1989 C2500. I purchased an ECM and wiring harness off of a similar pickup and installed it on the Nova. The problem is that it will start fine but once the engine gets warm it will start to run rough and then if you turn off the car it will not start for 15 - 20 min. During the time it will not start I notice that the injectors do not spray gas out, rather drops of gas come out very slowly. I had the ICM tested at an AutoZone and it tested fine. Any ideas?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 386 Answers

Check your fuel pump pressure , it could be you have a fuel pump that is getting hot and breaking down..

Posted on Sep 10, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Your right I didn't ask that question very well:( seems to be running very rich. Any suggestions . Has new TBI


There is no choke , has TBI - electronic fuel injection . May have a cold start fuel injector . IF not the engine computer know's it cold from the input from the coolant temp sensor an will richen the fuel mixture till it gets warmed up .

Mar 07, 2017 | Chevrolet Camaro Cars & Trucks

1 Answer

Will not start cold without a lot of tries runs fine warm?


the first sidekick ever. 1989. (and tracker)
the first few were made in Iwata japan then at CAMI (canada) then on.
first off this year, came with 2 engines, 1.3L carb and 1.6L TBI EFI.
so what engine? we can NEVER guess and engine, blind.
The CEL if a CEL , and TBI 1.6L engine G16A
that lamp can glow for 2 reasons in 1989-95.
Check engine. function
and what we call the NAG lamp.
http://www.fixkick.com/CEL/NAG-Lamp.html
the nag switch is hidden in 3 locations in 7 year span.
its just to make folks angry.... (Hiroshima>? revenge?)
on this car, if it has a NAG it on the bottom kick panel
between your legs, (toes)
and can never be seen. only felt (lacking a mirror)
NAG = federal (usa) mileage warning see if leaded fuel messed up the CAT ,deal,, (totally useless now)
We remove them at the cluster 3 wire connector forever.
so if present slide the switch 1 time.
now the CEL lamp can flash out flash codes.
http://www.fixkick.com/CEL/CEL.html
hard cold starts, if CEL flashes 12s does it?
causes (top, not a guess) I do tests to find these but takes TOOLS.
  1. never tuned up with all new spark parts and filters.
  2. cam belt slipped. (60k part)
  3. engine is flooding, high fuel pressure, (too high)
  4. TBI injector o-ring leaking. flooding starts.
  5. ECT wires fell off.
  6. map hoses bad. or clogged end to end. from plenum to map sensor insides (nipple not clogged either)
  7. not melted cat, runs fine hot.
  8. not code 12s flashing (good) so what is it flashing. ?
  9. stuck open EGR main, (that can bounce closed as you crank long then be ok... for a while, many old EGR like to stick just as you stop car and shut down) can be felt by hand on any 8v engine easy. the diaphram ring can be exercised with fingers.
  10. IAC bad, stuck closed, preventing cold start air . and flooding.
  11. ISC valve same.
  12. Dash pot valve stuck retracted. (clod start vacuum start)
  13. spark timed wrong , see cam belt slip.

Nov 06, 2015 | 1989 Suzuki Sidekick

2 Answers

Not turning on when warm.


Bad pickup, tough to replace if in the distributor. Also, pull out the computer, it may be located behind the glove box or under the seat. Unplug it and open it up. Look at the computer chips for one that looks burnt. If so, the pickup may also be bad.

Dec 06, 2013 | 1987 Chevrolet Nova

1 Answer

High idle


It's probably one of two things , a vacum leak or a bad ground.

Dec 23, 2012 | 1989 Chevrolet C2500

2 Answers

1989 tbi chev. 5.7 missing or trying to flood with


Try your coolant temp sender, if it's bad the computer thinks it's running cold all the time, therefor giving it more gas.

Oct 26, 2009 | 1989 Chevrolet C1500

1 Answer

I have a 1989 chevy pickup c2500 what is the fuel pressure


Hello! If you have the TBI engine it should be 9 to 13 pounds - if it's the SFI, it should be 40 to 55 pounds.


Hope this helps, and thanks for using FixYa!

Oct 22, 2009 | 1989 Chevrolet C2500

1 Answer

Injectors are not putting fuel into the TBI and eng wont start


Two things can cause that # 1 is the module in the distrubtor # 2 is the ECM.

Nov 30, 2008 | 1989 GMC C2500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

282 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...