Question about 2000 Mitsubishi Eclipse

Open Question

I need to know which fuse is the altenator fuse in my 2000 mits eclipse. The car will start up and run for about 5 seconds then just putter out and i was told this fuse may be blown

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: ac on 01 eclipse

Not sure about the ac/radio issue, although others have posted solutions for models later than yours. The oil leaking issue is more than likely a broken or cracked gasket where the pistons of the engine are located. May want to take it to a certified mechanic to get them replaced. Not a very expensive job on a 4-cylinder car. May also want to check the draining bolt where the oil is changed and the oil filter.

Posted on Jul 23, 2008

Ad
keemo68
  • 1263 Answers

SOURCE: ignition fuse

you have a short in the transmission control circuit. there is a good chance that because of the accident the mainharness was damaged. your transmission is locted on the drivers side so that would explain why your blowing fuses while shifting. I would start by looking at gthe main harness, and i would take it to a shop and have a diagnostic run on the transmission. please rate this...thanks

Posted on Sep 11, 2008

  • 23 Answers

SOURCE: I am trying to replace the front rotors on a mits

Rubber mallet. You can hit them pretty hard without damaging anything. If you have never done this I would start soft and work your way up.

Posted on Jul 20, 2009

  • 6 Answers

SOURCE: have a 1998 mits. Eclipse 2.4 L. Won't start. Has

need more info is the 12 volts steady ? have u checked wires and plugs? if the 12 volt to coil is constant have a look at your crankshaft position sensor...

Posted on Sep 01, 2009

  • 2 Answers

SOURCE: what kind of gear oil 99 mits eclipse spider 5

75W90 or 85W90

Posted on Mar 11, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2000 eclipse gt that had a bad wiring harness, we replaced it and idk if we just missed a plug or what but the only things working are the dome lights, door dinger, and power locks. the gauges...


even if you missed a plug, it should at least turn over. should not be reason why it won't start. check the fuse panels for bad fuses under dash and under hood. its possible you shorted it out when installing the harness. .good luck.... Mike

Jun 05, 2017 | 2000 Mitsubishi Eclipse

1 Answer

There is no power at the diagnostic connector of a 2003 Mitsubish Eclipse GS that I am working on. Any ideas?


Check the fuses, I'm not familiar w/ Mits., but I have run into 2 repairs where the diagnostic port would not provide engine codes to scan tool, both times it was a bad fuse, so no power at port (thought my scan tool was broken!) . One car (american manufacturer) had the fuse shared with the cig. lighter, check your fuse diagram to determine which one it is on your car. Hope this helps, good luck.

Nov 17, 2009 | 2003 Mitsubishi Eclipse Coupe

1 Answer

Have a 1998 mits. Eclipse 2.4 L. Won't start. Has


need more info is the 12 volts steady ? have u checked wires and plugs? if the 12 volt to coil is constant have a look at your crankshaft position sensor...

Sep 01, 2009 | 1998 Mitsubishi Eclipse

1 Answer

I am trying to replace the front rotors on a mits eclipse 2000 but the rotor wont's pop off. Any ideas?


Rubber mallet. You can hit them pretty hard without damaging anything. If you have never done this I would start soft and work your way up.

Jul 20, 2009 | 2000 Mitsubishi Eclipse

1 Answer

Had trouble starting the vehicle for two days on the second day when it finally started it puttered after it did start. let it set for a second to get itself going. when i put it gear kind of puttered some...


We have the same problem we changed the fuel pump and it fix the problem for about a week, the van started puttering and didn't start until the 20th try. Now we are looking at the fuel filter. What a way to spend the 4th.

Jul 01, 2009 | 2000 Chrysler Grand Voyager

1 Answer

Ignition fuse


you have a short in the transmission control circuit. there is a good chance that because of the accident the mainharness was damaged. your transmission is locted on the drivers side so that would explain why your blowing fuses while shifting. I would start by looking at gthe main harness, and i would take it to a shop and have a diagnostic run on the transmission. please rate this...thanks

Sep 10, 2008 | 2001 Mitsubishi Eclipse Spyder

Not finding what you are looking for?
2000 Mitsubishi Eclipse Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8575 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...