Question about 2003 Ford Thunderbird

1 Answer

I have a 2003 thunderbird, recently while trying to pass and accelerating I lost power and a little wrench showed up on my dash. This happened 5 times, we took it in the the garage and they replaced the ? (sorry my husband knows) and charged us $500.00. The problem occurred again with acceleration. If you pull over turn the car off and restart it resumes w/power. Do you have any idea what the problem is?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 1,986 Answers

It could be your ignition system (ignition coils, spark plugs, distributor cap) or your fuel system (fuel pump, fuel injectors, fuel filter, etc)

have it scanned to see if there are any trouble codes that appear as this will help narrow down the cause. Autozone offers this service for free

Posted on Sep 09, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2003 ford thunderbird pats will not let me start my car. The battery has been replaced. Recently and it will not let me crank the vehicle.... how do I reser the pats?


Are you sure it's a PATS problem ? Does your vehicle have the little red light on top center of the dash panel ? Does it flash when trying to start the vehicle ? If so the dealer or a moblie lock smith that can do a key relearn .

Apr 16, 2017 | Ford Cars & Trucks

1 Answer

Sputters on acceleration at 80 to 100 k


Do you notice any check engine lights coming on the dash when this happens, also has the vehicle had any recent repairs or any reason why this may be happening? Any input from you is helpful. I will check my resources and see what we can find out. Please advise

Jul 07, 2015 | 2003 Buick Regal

1 Answer

2003 blazer p301 code ive changed coil plugs check engen still flashing when accelerating


The flashing light means the problem is serious enough to damage the catalytic converter.
The code means cylinder 1 is not producing power. So it could be fuel, compression, or ignition related.

Feb 05, 2014 | Chevrolet Blazer Cars & Trucks

1 Answer

2001 Mazda MPV, 2.5L eng. During accelerating on to highway, van lost power. Van continued to operate but with little power available. I have no engine light and my code "checker" shows PASS (no...


looks like not enough fuel pressure, check the fuel filter.
and the fuel pump pressure.with car running 60 psi
the pump is located at the rear seat driver side you have to remove the carpet to access the cover. if the fuel pressure checked "OK" suspect defective maf sensor (sometimes defective maf sensor do not show errors codes)another way to test is disconecting the maf sensor and start the car (computer goes to limp in mode) and works little better,or check by scanner idle= low grams per seconds and increase when accelerate.

May 02, 2017 | 2001 Mazda MPV

3 Answers

I have a 95 Buick LeSabre and it recently started vibrating when I accelerate. I started only happening when i got to about 50 MPH but has steadily gotten worse. If I let off the accelerator it stops....


check the tires for separations or bulges in the tread face also check the drive axles see if the boots are torn or missing all together,also be sure to check the ball joints and tie rod ends.

Dec 26, 2009 | Buick LeSabre Cars & Trucks

2 Answers

I was driving up a moutain road, slowly, as it was unpaved and had potholes, and I lost power. I had driven up about 2500 ft, in a distance of about 5 miles. The engine was running, but when I put my foot...


if its is under warranty, rerurn to dealer with problem, seems like it is not switching from battery to gas correct, you may have a issue that only the dealer can correct with there computors

Oct 18, 2009 | 2006 Honda Civic Hybrid

1 Answer

No Power in Passing Gear


That means you're transmission is shot and you need to get a new one.

Mar 25, 2009 | 1997 Ford Thunderbird LX

1 Answer

When hitting passing gear no acceleration feels like it is trying


Proably one of your Coils has gone out. This generally happens with this car aroung 60,000 miles. These are coil on plug coils, which means you have 6. Nissan will want to replace all for $600+. Check this out for more details

http://forums.maxima.org/5th-generation-maxima-2000-2003/338587-got-bad-coils-i-tested-only-replaced-2-how-w-pics.html

Dec 23, 2008 | 2000 Nissan Maxima

1 Answer

My 1995 Mercedes Benz E420 has lost power gradually


Have you check the transmission fluid level? It sounds like it is low. You might not have a dipstick in that unit. I'd add at least 2 quarts and test drive it. 

Dec 21, 2008 | 1995 Mercedes-Benz E-Class

Not finding what you are looking for?
2003 Ford Thunderbird Logo

174 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...