Question about 1998 Ford Expedition

1 Answer

98 EXPEDITION, 5.4 LTR. RUNS ROUGH AS HELL IN PARK. A LOT OF VIBRATION.WANTS TO STALL UNLESS REVVED HIGH. DOESN'T WANT TO GO INTO REVERSE OR DRIVE, BUT IT WILL MOVE A LITTLE AT HIGH REVS. HELP PLEASE, IT'S THE WIFES RIDE.TRANNY FUID LEVEL GOOD.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,111 Answers

You truly need to have it serviced and im sorry to have to say that however it could be a sensor or the transmission itself look for vacuum lines that may be rotted or a plug that had disconnected but this sounds like you need professional hands on repair

Posted on Sep 09, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i fix a rough idle and stall?


Hi Cody:
I'd be checking all of the vacuum hoses and the PVC valve.
Also it wouldn't hurt to put some fuel conditioner like SEAFOAM through it.
My approach tends to be to make sure the basics are looked after before starting to second guess for major problems.
Cheers.

Oct 30, 2015 | 2000 Hyundai Elantra

1 Answer

Engine stalls while in drive and reverse runs rough in park or neutral


Begin with the basics......Start with a scan/check parameters

Jul 01, 2014 | 2002 Ford Excursion

1 Answer

Volvo 240 stalls unless giving it gas


Check the rpm in neutral should be around 800-850, this should drop to 500-550 in drive or reverse.

Mar 17, 2014 | Volvo Cars & Trucks

1 Answer

Expedition hard to shift out of park


More then likely the park lockout solenoid is sticking or the cable it operates is sticking.

Apr 20, 2017 | 1999 Ford Expedition

1 Answer

1993 LeSabre- just started running rough mostly when put in reverse or drive. Not so much in park or neutral but a little, maybe cause of higher idle speed in park. Also runs a bit rough at slow speeds....


Sounds like the Torque Converter Lock-up Solenoid is failing. It will cause the car to run rough at slow speeds, and sometimes stall while idling in gear (at a stop sign for example)
To test this, locate the 2 or 3 wire connector on the left side of the transmission (looking at it from the left side of the car, it can be hard to find some times) Disconnect it. If the car runs and drives ok with it unplugged, the Lock Up Solenoid has gone bad. The solenoid itself is inside the valve body, inside the transmission (above the transmission pan)

Aug 24, 2011 | 1993 Buick LeSabre

1 Answer

When put into drive the car shakes and stalls. It


I have a 1989 5-series BMW which sometimes stalls after changing from reverse to drive. It also sometimes shakes when first driving in reverse before changing to drive.

Jan 30, 2010 | 1992 Mazda Protege

Not finding what you are looking for?
1998 Ford Expedition Logo

301 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5481 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...