Question about BMW 525

1 Answer

The battery is not charging, and gauges are jumping, I can't blaim the altenator because even when the engine is off, but ingition is on,the gauges still jump i.e. speedometer, techometer, gas and temperature gauges are going back and fourth. Is there an electrical short somehere or what can it be? PLEASE HELP!!!

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 298 Answers

Get the battery replaced. It happened to me once on another car.

Posted on Sep 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why won't the newly installed altenator work on the 2006 Ford Taurus? The cars gauges stopped working and a red icon was lit up on the dash (appeared to be the check engine light) when the car was moving....


as its a used part it may not be in working order , check the charge rate by putting volt meter across the battery terminals when engine running , the reading should be around 13.5 -14 volts , if not then check the alternator belt is tight enough and retest the charge if lower than 12 volts then the alternator is useless , a non charging alternator will give the symptoms you've described, th ered icon is the non charging warning light , dont drive if the check is low as will ruin your battery as well, take alternator off and get a lift back to the supplier , best to by new

Jul 15, 2014 | 2006 Ford Taurus

2 Answers

After i had to jump start my 2006 mitsubishi galant, the engine started to rev up pretty high and when I put it in gear it went rolling kind of fast. I don't feel I can control the acceleration. What do I...


One possibility is you have corrupt data in the engine computer parameter memory due to the low voltage and jump-starting surges. Disconnect the battery, wait ten minutes, then reconnect the battery and follow the engine computer training procedure (this may be titled "After Changing the Battery") in your owner's manual. Usually it's something on the order of letting the engine idle for a period of time, shifting through the gears if you have an automatic transmission, then driving normally.

May 02, 2011 | 2006 Mitsubishi Galant

1 Answer

The truck stalled a few days ago. It was jumped and ran fine. Yesterday it stalls again, but won't the battery won't hold a charge. It was towed to the shop and they said everything tested fine once they...


sound like might have a prooblem with the charging system. if the altenator is not charging the battery while driving then when the battery voltage gets too low (prob around 10volts) then the computers will shut down, then when jump started it gets some power back, and when the battery is charged will all work fine for a while.
does your model have the voltage gauge in the dash? should be over 12 volts when engine running, 14volts is a good charge rate. and should stay up above 12 all the time, with lights on air condon etc...
and altenators can be funny, work sometimes, and not atother times,

Mar 24, 2011 | 2002 Mitsubishi Montero Sport

1 Answer

Charging problem gauge reads half charge has new altenator and battery


start engine and then disconnect neg battery terminal ,if engine stops alternator problem if engine keeps running then its ok and a gauge fault is the possible answer

Jan 05, 2011 | 1994 Chevrolet Lumina APV

2 Answers

Battery died (or not). When I give it a jump, the car starts, but as soon I remove the jump cable, car turns off.. What could be the issue>


Your issue is indicating two problems. First let's talk about how your charge system works so that you can see what happened. The battery is there to start the engine. At the point the engine starts, the alternator takes over and provides power to the engine and also charges the battery for the next time you start your car. If the alternator fails to work, the engine runs solely off the battery. The car should have indicated that the charge system is not working, maybe you saw a battery light on your dashboard. After some time, the battery is depleted and will not start the car or be able to run the engine. So it appears that you have a defective alternator, and also your battery is either discharged, or is also bad. When you hook up your car to jumper cables, you are running off of your buddy's charge system/battery, so when you disconnect them, your car dies.

Oct 19, 2010 | 2000 Mazda MPV

2 Answers

1994 olds cutlass supreme volt gauge shows low I have a new battery and a new altenator could the both battery and altenator put out correct volts no drain on battery even change dash volt meter still in...


check with a volt meter if u have 12 volt at the big lead on the back of the alternator engine off

if thats good start engine check to see if alternator is charging check the battery a good alterntor charges 13.5 - 14 volts, u may have a bunk alternator

Mar 25, 2010 | 1994 Oldsmobile Cutlass Ciera

2 Answers

1996 BMW 328 IC Convertible Altenator ok but not charging battery


Sounds like the alternator may be missing an excitation current source.
Check the 'IGN' dash indicator lights when you turn ignition switch on prior to starting motor,
if not one of the below may be problem:-
1) check exiter control wire is connected to alternator D+ terminal (low current wire, +V with Ign on),
2) replace dash 'IGN' indicator lamp.

Jul 10, 2009 | BMW 328 Cars & Trucks

1 Answer

Voltmeter drops to 9 volts on Chev 454 P30 motorhome


this is eithere a loose positive cable from the altenator to the battery or the regulator in the altenator is about to fail. if you have not had any problems starting the vehicle then most likely its a loose connection between the gauge and the charginging circuit or the gauge is faulty. take a multimeter and test the charging votage at the altenator while the vehicle is running it should measure 13.5 volts and should not change more than .5 volts. if the voltage drops more than 1 volt the regulater is bad and the altenator needs to be replaced. if it is working fine then looke for a bad connection make sure all positive and ground cables are tight. if they are replace amp gauge

Apr 19, 2009 | 1994 Chevrolet C/K 3500

6 Answers

Chevy blazer won't start


Well odds are that your blazer is fixed by now. Either way sounds like a bad battery, that's why you need jumps all the time. Why it would die, there are too many possibilties off hand. So what was wrong with it?

Jul 27, 2008 | 1999 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

129 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...