Question about 2003 Ford Expedition

Open Question

My 2003 Ford Expedition Eddie Bauer CD-6 Radio...I get CD Error messages when i try to play CD's now is there a fix?

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 ford expedition, eddie bauer, cd player has stopped working. I took the cd player out. Can I just replace the cd player instead of replacing the whole radio unit? I can't seem to find anywhere to...


Unfortunately not. The first thing I would try to do is get the cd player fixed by an audio store in your area. If it cannot be fixed, you will have to replace your radio unit. Let me throw this at you. I have invested in a whole new sound system in my vehical. I am not saying that all of your speakers need to be replaced, but an aftermarket stereo unit is more fuctional and stylish than than your stock stereo unit. Hope this helps! Please rate 4 thumbs up!

Apr 18, 2011 | 2003 Ford Expedition

1 Answer

2003 ford expedition, 6-disc cd player, several cd's in player, getting a cd error message. won't eject or play.


try disconecting te battery that way the cd player would reset itself and probably eject the extra cd...

Feb 11, 2010 | 2003 Ford Expedition

2 Answers

Ford Expedition 2003 6 CD changer contianing 6CD's says CD error


Try unhooking the battery for 5 minutes to reset the stereo

Feb 25, 2009 | 2003 Ford Expedition

1 Answer

98' Ford Expedition radio, cd wont work! no message or anything


There could be a fuse you are missing. I don't know your model well enough to say, but some have a separate fuse under the dash.

Jul 12, 2017 | 2002 Ford Expedition

1 Answer

Radio does not work but cd does


Mine had a similar problem (radio/tape casette days a 2 decades ago) Had to return the radio 3 times till they finally fixed it correctly. It was a problem internal to the radio. Sounds like you may have a compnent loose & not soldered well to the PC board. Or maybe it's a bad component & got fried. (output transistors ?)

Nov 18, 2008 | 2003 Ford Expedition

Not finding what you are looking for?
2003 Ford Expedition Logo

Related Topics:

882 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

79077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

fordexpert

Level 3 Expert

5677 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...