Question about 2002 Mercedes-Benz C-Class

2 Answers

Hood Open and Windshield wipers

I have a 2004 C240, Open hood dash light comes on at 3-5mph and will go off when speed picks up, just noticed the windshield wipers will not work until the car picks up speed over 5mph, both issues started at the same time last week. Can anyone help?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

I had the same problem with a C320 and I took it into a (Backyard mechanic) only to not have it solved! I am a helicopter mechanic and finally pulled it into the garage and troubleshot it myself. Here is what I found! When the hood shuts there is a sensor that sits right where the actual latch, allows the hook to (LATCH). My latch was loose!!! I tried it out from every angle and clipped it back into the latch only to have it (FIXED).... I fixed it myself and was really mad that I paid some ******** mechanic who didn't know what he was doing!!!!!! OH YEAH, The windshield wipers are somehow wired to the hood!!!! If you fix the hood the windshield wipers will work fine (I'm pretty sure)

Check the latch. I guarantee you it will probably be the solution.

Posted on Sep 07, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Mercedes-Benz Master
  • 1,348 Answers

Check the wiring harness on the drivers side.it has a broken ground wire more than likely.

Posted on Sep 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Whats the code to turn off windshield wiper fluid light off from dash. My windshield wiper fluid is full and light stays on. How do i turn it off? 2004 grand am gt


You have a lvl sensor located in the bottom of your washer bottle, you will either need to repair or change your sensor, or unplug the sensor to keep an open circuit.

Jun 30, 2015 | Cars & Trucks

1 Answer

I have a 2004 rx8 6 speed I put new battery in it and the horn blares not like car alarm type but just steady honk and the lights come on and the windshield wipers and my dash won't light up or anything!


Wrong, or still dirty connections... remove battery post bolts and clean or replace these bolts...reassemble with new battery and try again...

Oct 31, 2013 | Cars & Trucks

1 Answer

Delayed wiper and wiper windshield wash do not work, however normal and high speed wipers work properly


Hi, You have a blown fuse. Look in fuse box located under left dash by left knee. If not there look under hood near battery. Replace the fuse Good luck.

Oct 04, 2011 | 2002 Toyota Sequoia

1 Answer

Windshield wipers do not work. Car sat one day. Worked fine previously. 2004 Nissan Maxima. Had about 3" snow. No ice on car. Temp around 32 or 33 degrees. Brushed snow from car. Came off...


when you turn the wipers on do you hear any sound? If so, then you may have disconnected a ball joint in there behind the firewall - typically the top (black) panel (under the wipers/ at the back of the hood) comes off or you could find other access to inspect more thoroughly to be sure. If no sound, test the power to the wiper motor with a test light, if no power, check fuses, wiring, ground, etc.,
Best regards
Ck

Mar 06, 2011 | 2004 Nissan Maxima

1 Answer

Windshield wipers not working turn them on nothing is it a fuse? where would that be?


Should be under your dash or on the left side of it when you open your door. Might also be under the hood I'm assuming this is a dodge ram.

Jan 12, 2010 | 2004 Dodge Ram

1 Answer

2001 Ford F 150--Windshield wipers electric


You need to check your Fuses.. It sounds like you blew a fuse that controls Those Items..

Jun 12, 2009 | 2004 Ford F150

1 Answer

Windshield wipers dont work


Fuse # 5 in your panel should be a 20amp fuse, which provides power to wipers. Not 100% sure, but would bet there is a relay in that circuit before motor. Try to feel/hear, exactly where clicking is coming from. It is usually easy to simply narrow the click noise area down, then set finger lightly on relays, and feel it when it clicks. Pull it out & have tested or replace.

Feb 20, 2009 | 1994 Chrysler Town & Country

1 Answer

Windshield wipers only work on high setting and do not park


It is the Wiper Motor causing the Problem and will need to be Replaced. They could have caused it by Bumping the Wiper Motor Casing when replacing the Hood or when Working on the Motor. Please Rate my Response, I need all the HelpI can get! Thanks!

Jan 26, 2009 | 1997 Chevrolet Venture

2 Answers

Windshield wipers won't turn off 2004 Dodge Intrepid


I had a similar problem with a 2000 Dodge Grand Caravan. The windshield wipers turned on when someone turned the heater on in the car. They would not turn off at all, even when the car was turned off and keys were removed from the ignition. The only way to get them to stop is to pop the hood and find the fuse box on the van, and remove the 30 amp fuse for the windshield wiper. After removing the wiper motor and finding it was fine, we discovered the problem was in the relay in the fuse box. This relay is a little black box right next to the windshield wiper fuse and there are two of them, one for on/off and another for speed control. Our On/Off Relay had gone bad and was stuck in the on position, but it sounds like your Speed Control Relay may be bad. A new relay costs ~10$ at an auto part store. Just unplug the old one and plug in a new one, no need to unscrew anything, this was a 1 minute fix.

Nov 30, 2008 | 2004 Dodge Intrepid

Not finding what you are looking for?
2002 Mercedes-Benz C-Class Logo

333 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...