Question about 2006 Chevrolet Silverado 3500

2 Answers

No start on duramax at time when hot

07 duramax with dual tanks/ after driving for awhile then shut off and sets for 15/20 minutes will re-crank and run about 10 seconds / dies won't restart/ have to set for awhile then have to reprime fuel filter / starts and runs fine / when problem first started it was having long turn over time on every start/ replaced off brand filter with a wicks and the long turn over went away / a couple days later had the no start issue again/ do i have a fuel pump problem or is it the filter primer housing??
veh has a pump on frame by rear tank ? where is main pump
veh is a cab chasis.

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 636 Answers

Sounds like you are loosing the fuel prime from somewhere ? Not sure if you have a lift pump on the side of the engine on that model or not? follow the fuel rails from the tank pump up, and see if it runs into a lift pump or straight to the injector pump. I would guess that you are loosing your prime, so check the line and see if you if they are wet cracked or bent. also when you changed the fuel filter did you happen to notice if the o-ring came off with the last filter or not? You may just have doubled your gasket on the filter. Sometimes they stick on the filter housing and become unnoticed.
Hope this helps.

Posted on Sep 05, 2009

Testimonial: "i think its a pump issue /but its a 07 old body style(no lift pump)had 04 that i unplugged pump on frame /it still ran from front tank/2 pumps???"

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 582 Answers

IF THIS IS AN 2007 YEAR THE FUEL PUMP SHOULD BE IN THE TANK. IF THIS IS A DEISEL THE PUMP COULD BE ON THE FRAME RAIL BUT ONLY HAS ONE PUMP THE PUMP RUNS BOTH TANKS.
CHECK FOR ANY CRACKS IN THE FUEL LINE ALSO. BUT IT SOUNDS LIKE THE FUEL DRAINS BACK INTO THE TANK WHEN IT SETS THIS IS A SIGN THAT THE FUEL PUMP IS NOT HOLDING IT'S PRIME AND THIS NEEDS TO BE REPLACED

Posted on Sep 05, 2009

Testimonial: "this is my thoughts but i had seen some of the same problems in a article about the primer housing / the drain back is my first thought / thanks"

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2002 GMC Duramax LB7 won't start after I shut it off Already replaced the fuel regulator which the code came up Still have to crank and crank before it will start. Runs great once it's going. 160545...


Take vacuum hose off pressure regulator. If it is wet it's defective, Also sounds like fuel pump. Hit bottom of tank with mallet while trying to start.

Jun 09, 2014 | Cars & Trucks

1 Answer

Gmc duramax


you have probably got a partially blocked screen filter in the fuel tank

Oct 03, 2013 | Cars & Trucks

1 Answer

2001 ford taurus car starts fine drive it for awhile then shut it off and it wont start let it sit and it will start battery is fine


Does it crank?If you shut it off and you restart after a few minutes and it cranks but won't start or starts and runs rough the injectors are leaking and flooding the engine. Need better description

Dec 07, 2011 | 2001 Ford Taurus

1 Answer

Engine shuts off while car is driving. Still have all electrical. Try to restart car and motor will turn over but not crank. Try to restart car a few hours later and car starts and runs for about 10...


Many times a problem like yours can be traced to a failing fuel pump. When it gets hot it binds and stops, later after it cools off it functions normally 'till it gets hot again. Next time is dies, immediately turn the key off, then to the run position and listen for the pump (humming in tank) if you don't hear it, likely that's the problem. Never buy parts without testing though. A pump alone can set you back over $200.!!!

Apr 18, 2011 | 2003 Jeep Grand Cherokee

2 Answers

I have a 05 Chevy Duramax Diesel that is having issues starting. Randomly it will just not start. Turns over fine, but no start. Acts like it is out of fuel, but there is fuel. Let it sit a while,...


I am currently having the exact same problem with my '05 duramax. today for the first time it even died while driving and then would not restart for 5 minutes. If you figure this out please let me know. My email is travis.brown.23@hotmail.com
Im taking mine back in to have it looked at tomorrow.

Oct 23, 2010 | 2005 Chevrolet Silverado 2500HD 2WD

1 Answer

I have a 99 olds alero. I can drive awhile park the car try to start it and it won't crank. Newer battery and alternator. Mechanic is thinking manifold sensor. plz help


IF CAR TURN OVER NOT CRANKING AFTER A SHORT DRIVE WHEN ENGINE HOT.DIRTY CLOGGED FUEL INJECTORS FLOODING ENGINE OUT.CLEAN FUEL INJECTORS.FILL GAS TANK UP.PUT A CAN OF SEAFOAM IN FUEL TANK.DRIVE CAR AROUND TO HELP FLUSH OUT CARBON ON THE INJECTORS SEATS TO STOP GAS DRIPPING CAUSING FLOODING.IF CAR WONT TURN OVER.BAD BATTERY CABLES OR STARTER.SCAN IT FOR THEFT SECURITY PROBLEMS. IF STARTER TURNS OVER NO CRANK ENGINE FLOODING DUE TO DIRTY FUEL INJECTORS.

Sep 26, 2010 | 1999 Oldsmobile Alero

1 Answer

1993 Honda Accord LX Wagon won't start


Have you changed the crankshaft position sensor

Sep 20, 2008 | 1993 Honda Accord

1 Answer

No fuel pressure/shutting off


Try putting a new fuel pump in it or check the fuel tank switching unit it might have failed. (switch or unit under truck).I would go under truck and try to isolate one tank both electricaly and mechanicaly the see how it runs.

Aug 20, 2008 | 1987 Ford F 150

Not finding what you are looking for?
Cars & Trucks Logo

416 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...