Question about 1997 Chevrolet K1500

2 Answers

Not running 97 chev vortec. Replaced pump & filter. Still no starting on it's own. Put fuel in at throttle body and it will run only untill that fuel burns off. Pressure just behind at the little end when pushed down. Please help!

Posted by on

  • jatncbeach May 11, 2010

    Is there fuel pressure? Did you use a fuel gauge? If no, is there power at the fuel pump? Power will only be on for about 3 seconds. Best to have some one turn the key on while you watch the voltmeter or test light. It cycles out do to the relay. Let me know how it goes.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

If this is a cpi you will have to take the tot of the intake off to get to the injectors they all come off take the plastic tubes and put them i hot water for a while then blow them out 1 at a time it can be done

Posted on Sep 08, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Chevrolet Expert
  • 332 Answers

Sounds like the fuel presure regulator isnt working did you check the wiring and the fuse ?

Posted on Sep 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Fuel delivery problems


Is this a vortec engine, and have you checked fuel pressure with a gauge ?

Jul 21, 2013 | 1996 Chevrolet Blazer

1 Answer

94' blazer will not strart just died one day while driving it .i replaced fuel pump,fuel filter,fuel ragulater, if you spray starting fluid in it it will start but then die whin the starting fluid burns...


check to make sure they sold you the right fuel pump. they are two pumps for a 4.3 ones a vortek and one is a throtlle body. the eighth digit of the vin will tell you one is a vin w and one is a vin z. the throtlle body only puts out about 11psi of pressure and the vortek puts out about 60psi of pressure.if you put the throttle body pump in a vortek engine there is not enough fuel pressure to run it.

Oct 20, 2010 | 1994 Chevrolet S-10 Blazer

1 Answer

97 jimmy runs when you pour gas into throttle body, fuel pumps is putting out 55 to 56 psi. but will not pickup the gas from the injectors, fuel manifold psi is 55 to 56psi. 1997 4.3 vortec engine


If the 8th letter of the VIN # is W which i bet it is than your fuel pressure is to low.

This engine uses a CPI unit to deliver fuel to the cylinders. The CPI unit consists of a central injector that feeds fuel to the poppet valve that are right above the intake valves. The poppet valves require high fuel pressure in order to open and deliver fuel to the cylinders at start up.

The reason why it starts and runs if you add a little gas through the throttle body is that once the vehicle is running the intake is under vacuum. The poppets can open with less fuel pressure in a vacuum. This is a real common scenario with these style injection systems.

A new good quality fuel pump (a/c delco or delphi are good pumps) and your fuel pressure should be back into spec of 58 psi or more and the vehicle should fire right up. Make sure you replace the fuel filter when you replace the pump.

Oct 17, 2010 | 1997 GMC Jimmy

1 Answer

Hello, I have a 97 Blazer that starts intermittently and will shut down for no reason. Fuel pump was replaced about 24000 miles ago (are you supposed to hear the fuel pump working? I don't), I replaced the...


You should hear the whining coming from the pump when the key is turned on.If you suspect he fuel pump check fuel pressure if possible or try hitting the bottom of the tank and see if it starts then.The Vortec 4.3 requires a minimum of 54lbs of fuel pressure to start.It will run on less once it is running.Will it start with an alternative fuel such as throttle body cleaner?

Jul 04, 2010 | 1999 Chevrolet Blazer

1 Answer

99 silverado 4.3 vortec. engine turns over rapidly. plenty of spark. fuel pump runs. fuel filter not clogged. when i pour gas into the throttle body it runs until that gas runs out. what gives?


put a fuel pressure gauge on it. Check my specs because I am doing this from memory but I think it has to have at least 61 psi and anything below about 55 is not enough. I once put a brand new from the dealer on my bravada. Abter it still did not start I replace the "injector spider" to the tune of 400 buck my cost for the part only to find that the brand new feul pump was not getting enough pressure. Section 4 in a haynes manual at the parts store will give you the minimum fuel pressure.

Aug 16, 2009 | 1997 Chevrolet K1500

4 Answers

Engine wont start without priming with gas first, then runs well


i have the same problem on a 98 jimmy 4.3 4x4.
i replaced the fule pump and have good pressure.
new wiers & coil (good spark) no MIL & no codes.
will only start when primed. it will run & drive all day
with no problems.
but once it has been turned off (warm or cold) i will
have to prime it once again to start it.
i have another engine that was in it before it spun a bearing.
it ran fine so i know all parts are good.
i swaped the mass air flow and throttle body but i still have
to prime it everytime to start it. am i forgetting something?
should i swap out the intake with the injectors?
any help would be sweet. thanks.

Apr 28, 2009 | 2000 Chevrolet Blazer

1 Answer

Truck won't run


fuel pressure regulator might be to blame,on vortec models it is located under intake manifold plenum bolted to cpi unit and not real easy to change,o2 sensors will not keep it from running only affects how it runs,on your 96 i think there are 2 o2 sensors before the catalytic converters and 2 after.

Mar 29, 2009 | 1996 Chevrolet K1500

3 Answers

1996 GMC Sierra 1500 truck fuel problem


Have you check the injector relay or maybe a fuse for injectors.

Aug 26, 2008 | 1996 GMC Sierra

Not finding what you are looking for?
1997 Chevrolet K1500 Logo

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7710 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...