Question about Chevrolet S 10

1 Answer

1999 model S10, 2.2 liter. Just got oil changed this morning. Started fine , then i drove home. Now it won't start. Everything is fine electrically, but engine isnt wanting to turn over. Getting no oil pressure reading when trying to start.

Posted by on

  • 2 more comments 
  • mvs0978 Sep 04, 2009

    I hear the hum of the fuel pump, but when i turn the ignition the engine tries to turn over, but nothing happens.

  • mvs0978 Sep 04, 2009

    I have been recently trying two or three times to get it to turn over. Bad starter perhaps?

  • mvs0978 Sep 04, 2009

    I got the battery replaced back in Feb, and the alternator soon thereafter. So most likely its my starter or the solenoid? Just tried to start a minute ago, all i get is the hum of the fuel pump. Engine doesnt try to turn at all. The times it has, it has been very choppy.

  • mvs0978 Sep 04, 2009

    Just one single click from the turn of the ignition, then nothing.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 75,051 Answers

Does the engine crank? but just not start up? if so see if the oil pressure sending unit was disconnected during the oil change.

Posted on Sep 04, 2009

  • 2 more comments 
  • yadayada
    yadayada Sep 04, 2009

    does the engine crank? but just not start up? if so see if the oil pressure sending unit was disconnected during the oil change.

  • yadayada
    yadayada Sep 04, 2009

    does the engine crank? but just not start up? if so see if the oil pressure sending unit was disconnected during the oil change.

  • yadayada
    yadayada Sep 04, 2009

    have the battery tested 1st, if it is ok then suspect the starter motor solenoid.

  • yadayada
    yadayada Sep 05, 2009

    still have the battery tested, I went through 3 Kragen auto premium batteries before giving up and buying a Delco brand, that was years agO and still going strong, the lesson i learned? Delco and Motorcraft batteries are the best money can buy, it may not be the problem but at least eliminate it before replacing the starter, also check to make sure the starter solenoid wire has 12 volts when u hold the key in the crank position, the wire is PURPLE IN COLOR, IF IT DOESN'T GET HOT THEN YOU MAY HAVE A DEFECTIVE NEUTRAL START SAFETY SWITCH OR IF MANUAL TRANS A DEFECTIVE CLUTCH SAFETY SWITCH...

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 1999 chrysler seabring coup started fine yesterday morning drove kid to school came home put brakes on it started it pump the brakes few time put n reverse died wont start


HI,THAT IS A USUAL ISSUE RELATED TO THE ELECTROMAGNET WHICH IS ENGAGED ON "P or N" position.Charge your battery overnight,try your handbrakes,if they work fine,just leave the car in whenever you stop and put your handbrake on.This won discharge then the battery unless there is a unrelated electrical fault in the system.

Dec 18, 2014 | 1999 Chrysler Sebring

1 Answer

Where is the fuel filter on this car? Car was running fine, this morning I started it up, missing alot, A/C made it worse. I drove it to church 4 miles and when I started it up to come home check engine...


hey mine is missing to it is not shifting into reverse right it slams everything i have found points to the pcs pressure control syloniod i also filled up and got 20 miles and used half a tank

Jun 06, 2010 | 1999 Saturn SL

2 Answers

My 1999 yukon wont start i changed master air flow


Fuel pumps are real common to go out on those vehicles

Mar 15, 2010 | 1999 GMC Yukon

1 Answer

Missing in my 5.4 liter triton engine


What year is it? F-150? It likely has a bad coil.

Jun 26, 2009 | Isuzu Trooper Cars & Trucks

1 Answer

I have a 1999 buick regal ls dying.


Check the harmonic balancer

May 26, 2009 | 1999 Buick Regal

2 Answers

Stalls / Dies / dead


this engine fuel pump prassurae low. it fuel pump celan. Your problem sovel

Jul 13, 2008 | 2003 Ford E150

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

392 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...