Question about 1987 BMW 3 Series

1 Answer

87 325 runs good when cold then starts dieing idling up and down

Is it the oxy sensor

Posted by on

  • kevin butler May 11, 2010

    is check engine light on.. need to scan and pull codes

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

I would suggest changing the FUEL PRESSURE REGULATOR mounted on the fuel rail with a vac line going to it.
it could be a number of things, if it dies when its warmed up it is most likely a faulty fuel pump on its way out, but it could be anything, need more info. 
Check the spark plugs, change the fuel filter, when was the last time the timing belt was done? how many miles are on it? 
lastly sometimes these cars have old relays, as found on the e28, they were known for not working when they warmed up, change the fuel pump relay with a new one ($7) just to be safe.

Posted on Sep 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a vn commodore on start up when it is cold it will idle but if u give it a little rev it will die after 30 seconds it wont then drive down the road ten minutes it will die note running fine and just...


Hi Daniel, The problem sounds to me as if it has to do with the temperature sensor which sends signals to the ECU. The sensor is nothing to do with the gage on the instrument panel, but instead signals the the ECU to increase fuel richness for cold start and cold running. Have a diagnostic scan carried out, and check for disconnections or broken cables, if the connections and cables are good the defect may not show on the scan, but replace the sensor anyway. I think that will solve your problem. Regards John

Oct 17, 2012 | Holden VN Cars & Trucks

2 Answers

Engine starts , and dies. Only when weather is cold.


hello there
I looks like your oxygen sensor,Try to disconnect and then see what the car does?Let me know.You may need to adjust the fuel mixure,seem it is running a little rich that is why the car in idle goes up and down.
proporsche@yahoo.com

proporsche

Jan 09, 2012 | 1991 Porsche 911

1 Answer

1994 chevy with 5.7 L with throttle body inj. when i start it the idle drops down and sometimes dies. when you put it in gear idle drops really bad and sometimes dies. once i'm going down the road the...


Sounds like you have a vacuum leak. When the engine is cold the leak is there but as the engine warms up the parts start to expand thus closing the gaps and sealing the leak. I had this problem on my personal vehicle and it turned out to be lower intake gaskets.

Jan 29, 2011 | 1994 Chevrolet C1500

1 Answer

My truck began running very rich little by little.


FROM WHAT I FOUND OUT ON MY SAME TRK ONLY 94' IS THE DIAPHRAM ON THE FUEL PRESSURE REGUALTOR IS SLUGGISH OR BLOWN. DISCONNECTING THE VACCUM LINE AND PLUGGING THE MANIFORD PORT HAS HELPED UNTIL I AM ABLE TO AFFORD THE REGULATOR. TO HELP CLEAN THE OXY SENSOR, SPEED UP THE IDLE AND DISSCONNECT THE BRAKE BOOSTER VACCUM LINE AT THE ENGINE. THE FRESH AIR WILL SOMEWHAT HELP CLEAN THE SENSOR IF IT IS ABLE TO BE HELPED. I AM TOLD THAT THE OXY SENSOR ON THESE MODELS IS CRIDICAL. JACK

May 13, 2010 | 1986 Nissan Pickup 4WD 1986

1 Answer

I have replaced coil pack, plugs, all three sensors, all new injectors, code is P150...idles a little rough on start up when cold only then runs perfect....help..2004 deville base Y


P0150 Oxy Sensor Circuit Bank 2, Sensor 1. P0151 Oxy Sensor Circuit Lo ...
oyur o2 sensor is bad on bank 2 is opposite from number one cylinder should be passenger side intake manifold o2 sensorfirst sensor there needs replacing

Mar 06, 2010 | 2004 Cadillac Deville

2 Answers

Truck wont stay running


CHECK DISTIBUTOR ROTOR FOR BURN THROUGH IN THE CENTER OF ROTOR....IM ASSUMING ITS LOSING SPARK

Aug 31, 2009 | 1998 Chevrolet S-10 Pickup

1 Answer

1988 gmc s15 2.5l 5spd/starts strong then dies


Have you tried replacing or testing the fuel pump and/or filter?

Feb 25, 2009 | 1988 GMC S-15

4 Answers

Mazda 626 engine cut off when excel over 3000 rmp


my 1988 mazda 626 starts okay then dies everytime it idles down to normal idle speed. i replaced the throttle control sensor and the mass air sensor. i replaced the rotor in the distributor but is still dies. if you throttle up to about 1500 rpm it keeps running. any ideas???

Aug 04, 2008 | 1994 Mazda 626

Not finding what you are looking for?
Cars & Trucks Logo

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Frankie B

Level 2 Expert

65 Answers

Fred Sops

Level 2 Expert

272 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...